cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
itsJoost
Level: Power Up

Re: Nested gallery, trying to collect data from 1st sub gallery

Hi @wyotim,

Thanks for explaining this, for now I will eloborate some more on the dubble click issue. I have got a nested gallery with records. For now it contains some dummy data (in Dutch). As soon as I click a record, the view form shows me the data through the hidden gallery. As soon I click a new record the view form shows me a dutch message which is translated: "There is no item to display". As soon as I click the record for the second time it does show up in the viewform. 

I want it this way because I want to show the attachments that below to the corresponding list items.

The code I use:

For the records (ending with a number) in the nested gallery I use for OnSelect:

UpdateContext({HiddenGalleryID:ThisItem.Id})

For the hidden gallery I use for Items:

Filter(Processenboek; ID = HiddenGalleryID)

For the viewform I use for Items:

HiddenGallery.Selected

Hope this explains my situation, it would be awesome if you could shine your light on this;)


Super User
Super User

Re: Nested gallery, trying to collect data from 1st sub gallery

Hey @itsJoost, apologies for the late reply; life's been a little busier than I like it lately! Smiley Frustrated Smiley Very Happy

 

After looking at your examples, I made a test app in the same way you described. Unfortunately, I couldn't replicate the issue you are experiencing. For the record, I am using sample data from an Excel document on OneDrive for Business, so I don't know if your data source has a part in the issue you are experiencing.  

 

One suggestion: rather than collecting the ID and using the hidden gallery for the form, what about using the variable itself to feed the form? this would bypass the need for the hidden gallery altogether. So in the OnSelect, try:

// OnSelect of the nested gallery item
UpdateContext({FormItem:ThisItem})

Then in the form's Item property, put:

// Item property of the form
FormItem


I tested this method and it worked, but that isn't too helpful as I couldn't replicate the issue in the first place. Maybe try it out and let me know if it works. I'll respond in a more timely manner this time!

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 173 members 5,408 guests
Please welcome our newest community members: