cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
KOM_4410
Level 8

New problem when changing versions

I have an app that basically submits a form from PowerApps to Sharepoint list.

The app has been working well for a while now, but suddenly one of the columns stop populating (the most important one, unfortunately).

 

It is a multiline text column (pretty simple) that I haven't touched at all. Trying some troubleshooting I removed the "Use enhance rich text..." option and even removed the datacard from the PowerApp form and add it again but nothing seems to work.

 

Exploring a little bit further, the bug seems to start when the POwerApps version moved from version 3.19074.24 to version 3.19075.21. 

 

Any help please!

 

@JoeF-MSFT 

44 REPLIES 44
Powerhungry
Level: Powered On

Re: New problem when changing versions

Also alignments and positioning of labels,buttons,etc has been broken in 3.19075.21.

gj84uw
Level: Powered On

Re: New problem when changing versions

@Powerhungry @KOM_4410 

 

I've had quite a few issues with 3.19075.21 also.  I've got a multi-screen app that on the new version either doesn't populate fields in forms or even worse loads a form with an incorrect record.  I restored an earlier version of the app when I was troubleshooting and this restored version is now showing as release 3.19071.14 and the issues are no longer happening.

 

I don't know if this will eventually be updated to 3.19075.21 though and the problems will reoccur?

PClancy_F242
Level: Powered On

Re: New problem when changing versions

I had this problem also today, and I ended up adding to the OnSelct attribute an instruction to:


ResetForm(FormName)

 

before navigating to the view form screen.

 

This seems to have fixed it.

Community Support Team
Community Support Team

Re: New problem when changing versions

Hi @KOM_4410 ,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

Please consider take a try to restore your PowerApps app to previous version, then try it again, check if the issue is solved.

More details about restoring app to previous version, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/restore-an-app

 

In addition, you could also consider edit your app using the following previous version of PowerApps Studio:

https://create.powerapps.com/v3.19054.15.115879415/studio/#

 

If the issue still exists, please consider re-create a new app based on your SP List data source, check if the issue is fixed.

 

I also agree with @PClancy_F242 's thought almost, please also consider add the following formula within the OnSelect property of the "Navigation" icon (click it to navigate to your Edit screen) to following:

ResetForm(EditForm1);
EditForm(EditForm1);
Navigate(EditScreen)

Best regard,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
gj84uw
Level: Powered On

Re: New problem when changing versions

Thanks guys, adding the ResetForm() on the button that navigates to the form seems to have resolved the issue.  Out of curiosity is this something I should have been doing anyway as best practice or is it an additonal thing needed to get around any changes made in teh latest release?

Mattbart
Level: Powered On

Re: New problem when changing versions

I spent hours last night trying to get cascading dropdowns to work, after much help from someone on the PowerApps Facebook page going back and forth with different versions of code, finally got it to work!!  Didn't make sure the rest of the app still worked cause there was no reason to as it wasn't touched.   Wake up this morning at work to actually use the app for its intended purpose and find all formatting messed up, variables not cooperating, etc..  I also found this happened when PowerApps moved from version 3.19074.24 to version 3.19075.21!!   I am SOL with my business right now, I literally cannot function without this app.  I restored my app to the previous version, but it still updates the POwerApps version so all of these bugs still exist.    I don't know what to do...

gj84uw
Level: Powered On

Re: New problem when changing versions

@Mattbart 

 

I'm not sure what the support is like for PowerApps but could you try raising a support request via the Office 365 admin portal?  If you haven't made any changes to the rest of the app and it's having problems since the update then Microsoft may be aware of issues and could help?

Mattbart
Level: Powered On

Re: New problem when changing versions

@gj84uw  Just did, it said minimum 48 hours to respond.  UGH.

 
Microsoft Employee

Re: New problem when changing versions

Hello everyone,

 

I'm sorry to hear you're experiencing issues with the form, but thank you very much for reporting it!

Would any of you be willing to provide session ids to help our investigation?

(Directions for finding a session id can be found HERE)

 

- Paul C.
Software Engineer on PowerApps

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,554)