cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
schuess
Level: Powered On

No Data Populating on initial load of SharePoint List based PowerApp

Hi Everyone,

 

First Post. First PowerApp. Excitied to build!

 

I am just trying to learn and thus attempted to create a PowerApp based on a SharePoint List in SharePoint Online. These are the steps I have taken.

 

  1. New App
  2. Choose SharePoint Online Site
  3. Choose SharePoint List
  4. Create....

Result

  • I have the 4 default screens
    • BrowseScreen1
    • DetailScreen1
    • EditScreen1
    • Screen1
  • The BrowseScreen 1 seems to have controls on it that point to fields in the SP List, however no text is shown.
  • When i click on the preview button, still no data is shown
  • The DetailScreen1 shows the field titles, with no data
  • The Edit Screen1 shows an edit form for many of the field titles

Why do i not see list data like i do in the tutorials i am reading about and watching?

 

Capture1.PNG

 

 

BTW: YES THERE IS A DATA IN THE LIST. 🙂

 

Thanks for taking the time to help. Anything is appreciated.

Schuess

5 REPLIES 5
BeckyBertram
Level: Powered On

Re: No Data Populating on initial load of SharePoint List based PowerApp

I have found that the desktop PowerApps Designer application can cache data. For example, if I create a list in SharePoint, create my PowerApp, then go back and add an item to my list in SharePoint (after the PowerApp has been created), I don't always instantly see the new data. To be on the safe side, I suggest saving your PowerApp, closing down the desktop PowerApps application, and then restarting your app and confirming there's no data in there.

Savvy Technical Solutions Listen // Advise // Develop // Teach
Power Automate Staff SameerCh
Power Automate Staff

Re: No Data Populating on initial load of SharePoint List based PowerApp

 

There are two possible sources of error:

1> The API call to the SharePoint connection does not return any data.

2> The API call returns data in a format that cannot be parsed or displayed by the client.

If you can use a tool like Fiddler to catpure the traffic (or the Browser developer tool, F12) from the client and the service, we can help debug the issue.

 

Thanks!
Sameer

schuess
Level: Powered On

Re: No Data Populating on initial load of SharePoint List based PowerApp

I have the fiddler capture. What kind of info can I provide for you. What exactly should I look for?
Power Automate Staff SameerCh
Power Automate Staff

Re: No Data Populating on initial load of SharePoint List based PowerApp

Did you see any calls to the sharepoint connection?  The URL will start with "https://msmanaged-na.azure-apim.net/apim/sharepointonline". Eg. https://msmanaged-na.azure-apim.net/apim/sharepointonline/{connectionId}/datasets/{siteUrl}/tables/{...

 

If you can send that info to sameerch @ microsoft.com, I will follow up directly.

 

Thanks!
Sameer

schuess
Level: Powered On

Re: No Data Populating on initial load of SharePoint List based PowerApp

Thanks Becky, but didnt seem to fix my issue. We are going to analyze my fiddler output now. 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,925)