cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
codebrane
Level 8

Office 365 Outlook connector always uses signed in user's account

When I go to File -> Connections -> New Connector -> Office 365 Outlook, it displays my logged in username and asks if I want to choose another account. I choose another account, enter the username@domain and it takes me to my organisations sign-in page where it signs me in as the currently signed in user, not the user I requested as it never asks for the password. I've tried switching accounts on the incorrect connector but it always ends up as my account. Is there a way to add a connection for sending emails using an account that's not signed in?

 

thanks,

 

Alistair

 

1 ACCEPTED SOLUTION

Accepted Solutions
codebrane
Level 8

Re: Office 365 Outlook connector always uses signed in user's account

I seems the Office 365 Outlook connector is a red herring as it doesn't allow switching users when designing the app. After sharing the app and the sharepoint list it uses as a DataSource with another user, the app asks the user to allow use of their sharepoint/outlook accounts when they run the app. The app then sends as the user who is using the app. So it's not possible to send email from a designated account as that non-existent user would need to use the app.

 

View solution in original post

4 REPLIES 4
Community Support Team
Community Support Team

Re: Office 365 Outlook connector always uses signed in user's account

Hi @codebrane,

 

Could you please share a bit more about your scenario?

Further, do you want to create a connection to Office 365 Outlook connector using another account within your app?

 

I have made a test on my side, and don't have the issue that you mentioned. The screenshot as below:Test1.gif

 

 

Please take a try to clear cache of your browser, and then try it again on your side, check if the issue is solved.

 

In addition, you could also take a try to remove all connections to Office 365 Outlook connector from the Connection list within your PowerApps web portal, then create a connection to Office 365 Outlook connector with another account again, then check if the issue is still exists.

 

More details about adding or deleting connections in PowerApps, please check the following article:

Manage connections in PowerApps

 

 

Best regards,

Kris

 

 

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
codebrane
Level 8

Re: Office 365 Outlook connector always uses signed in user's account

thanks @v-xida-msft

 

The scenario is I have created a PowerApp that lets tutors grade students in the field and the app needs to send the grades to the student that's being graded. At the moment it uses my personal Office 365 Outlook account so the emails come from me. I have been given a new Office 365 Outlook account to use. i.e. the app will send using that account rather than mine. The issue is, I can't set up an Office 365 Outlook connection in the app that uses the other account. When I choose "Use Another Account" when creating the connector I enter the other account's username and it sends me to my organisation's STS but it doesn't ask for the password and when it returns to the new connector setup page it duplicates my existing connector which uses my account. I've also tried logging in to Outlook separately using the other account so it shows up in the list accounts to use in New Connector but that doesn't work either. It always duplicates my existing connection which uses my personal Outlook account.

 

Do I need to add the other account as a user in the app? That bit intrigues me as I'm fairly new to PowerApps and it sounds like it might help, if I knew what it meant!

 

Alistair

 

codebrane
Level 8

Re: Office 365 Outlook connector always uses signed in user's account

I can put anything in the new connection email address as long as it's in our domain but no verification by Office 365 (our STS) is ever performed and it comes back to PowerApps as my connection, which is then duplicated by PowerApps.

 

Is there an accepted way of sending emails from a powerapp using an Outlook account that doesn't belong to the designer? i.e. not using the account of the developer who is building the app?

 

codebrane
Level 8

Re: Office 365 Outlook connector always uses signed in user's account

I seems the Office 365 Outlook connector is a red herring as it doesn't allow switching users when designing the app. After sharing the app and the sharepoint list it uses as a DataSource with another user, the app asks the user to allow use of their sharepoint/outlook accounts when they run the app. The app then sends as the user who is using the app. So it's not possible to send email from a designated account as that non-existent user would need to use the app.

 

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 211 members 5,332 guests
Please welcome our newest community members: