cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
adstar22
Level: Powered On

Patch applies default value and not entered value for single line of text field

I am having massive issues with syntax for a patch command, which have been masked by a miss match on field types between the powerapps screen / patch command / sharepoint list.

 

https://powerusers.microsoft.com/t5/PowerApps-Forum/Sharepoint-List-record-update-FROM-powerapps-col...

 

I have (I think) proven I am updating the correct item in my sharepoint list.. by trying to submit a simple single line of text field. However, I am only getting the default value, and not the entered value!

 

Current code:

If(Form1.Mode=New,SubmitForm(EditForm1);Refresh('Sys Inventory AW');Patch('Sys Inventory AW',Last('Sys Inventory AW'),{Business_x0020_Impact:BusinessImpact.Selected},{Business_x0020_Impact_x0020_Justification:BusinessImpactJustification},{Compliance_x0020_Status:CompStatus.Text}),Patch('Sys Inventory AW',BrowseGallery1.Selected,EditForm1.Updates,Form1.Updates));Navigate(BrowseScreen1,Fade)

 

CompStatus is the renamed auto generated DataCardValue field. In here I have set the default value to "None Compliant"

When I run/preview my app I enter something else in the form field "Changed entry" for example.

I submit the new entry, and now I successfully patch the DEFAULT VALUE to the new sharepoint record!

 

WHY? What!? What do I need to do to submit the current text entry of the textbox or even the datacard it is within (noting that the update value of the datacard is CompStatus.Text)

1 REPLY 1
Community Support Team
Community Support Team

Re: Patch applies default value and not entered value for single line of text field

Hi @adstar22,

 

I replied on your previous thread:

https://powerusers.microsoft.com/t5/PowerApps-Forum/Sharepoint-List-record-update-FROM-powerapps-col...

For the default record issue, please take a try to replace the ComStatus.Text with:

Editform.LastSubmit.Compliance_x0020_Status

I think the issue here should be the Submitform function.

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,960)