cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dileep_gopalakr
Level: Power Up

Picking lists are not working if the app deployed to new environment, getting id does not exist error

Hi Experts, 

 

When i try to import a solution(Managed and unManaged) with multiple apps and enities or single app package from my dev enviromnet to test environment im getting below error on apps with picking lists or two option fields , also none of the fields are populating data.

Even standard picking list field are not showing up.

 

The specified record was not found.
Server Response: Navigation property Attributes With Id = 1fd1b85b-8770-e911-a97c-000d3a3ab6b4 does not exist
on Metadata Entity with ID = 5092abcb-c7b7-464e-a48f-c2c1a9b46

 

if i tried edit the app then delete and re-add the same fields the error is vanishing, but if I deploy a managed solution its not possible at all. Any suggestions will be helpful

 

Thanks in advance

1 ACCEPTED SOLUTION

Accepted Solutions
Helpful2
Level: Powered On

Re: Picking lists are not working if the app deployed to new environment, getting id does not exist error

5 REPLIES 5
Community Support Team
Community Support Team

Re: Picking lists are not working if the app deployed to new environment, getting id does not exist error

Hi @dileep_gopalakr ,

Do you deploy an app within a Solution from one Environment to another Environment?

 

When you deploy an app within a Solution from one Environment to another Environment, the connection within your app created within previous Environment would be invalid within the new Environment.

On your side, you should create a new connection to the same Entity within your target Environment from your app, then re-publish your app, check if the issue is solved.

 

In addition, please also make sure the Target Environment has same Entity data source as that in your source Environment, and you have configured same Option Set (Picklist) within the Target Environment.

 

O your side, please consider configure same Option Set (Picklist) within the Common Data Service of your Target Environment (as that in your Source Environment), and deploy same Entity within your Target Environment as that in your source Environment.

After that, re-create a new connection to the Entity in your Target Environment from your app, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
dileep_gopalakr
Level: Power Up

Re: Picking lists are not working if the app deployed to new environment, getting id does not exist error

Yes , I'm trying to import the managed solution to another enviornment.

But I'm wont be able to the editing the apps becasue its a managed solution.

Also the enities and powerapps are part of the same solution.

Community Support Team
Community Support Team

Re: Picking lists are not working if the app deployed to new environment, getting id does not exist error

Hi @dileep_gopalakr ,

Currently, I could not reproduce your issue on my side.

 

As an alternative solution, please consider import an unmanaged solution from your Source Environment to your Target Environment rather than managed solution.

 

Currently, within PowerApps, there are some unknown issues with the app connections in a Solution when import a Solution from one environment to another one.

If you want to get further help in this issue, please consider submit an assisted support ticket through the following link:

https://powerapps.microsoft.com/en-us/support/pro

 

There are also some known issues/limits when you use Solution within PowerApps:

https://docs.microsoft.com/en-us/powerapps/maker/common-data-service/use-solution-explorer#known-lim...

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helpful
Level 8

Re: Picking lists are not working if the app deployed to new environment, getting id does not exist error

I am currently experiencing this issue and have not found a solution anywhere.

Can someone weigh-in?

Helpful2
Level: Powered On

Re: Picking lists are not working if the app deployed to new environment, getting id does not exist error

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,597)