cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MoodyMas
Level: Powered On

Populated Lookup Field is sometimes not being displayed

Hello,

 

To me this is a mystery. All the lookup fields of a entity that have been populated and are definitely recorded sometimes do not display.

 

So I have a display form that gets its item from a gallery, and all the other Fields display perfectly apart from all the lookup fields. It is a issue in the Development environment, the Mobile and PC APP.

 

Please can someone let me know how I can fix this, the app has formally gone into production in the work force and this is causing problems.

 

Thanks in advance!

4 REPLIES 4
Community Support Team
Community Support Team

Re: Populated Lookup Field is sometimes not being displayed

HI @MoodyMas,

 

Where is your entity from ? CDS ?Dynamics 365 ?

 

I assume that the entity is from CDS .

I have made a test . There’s no issue on my side.

2.PNG

10.PNG12.PNG

 

Please check if you save the selected value to the lookup field .

You can create a collection from the entity and check if the lookup field in collection is blank.

 

Please try to remove the relationship and re-create a new relationship to another entity.

If the issue is still existed , please try to re-create an App and check if it is solved.

 

Regards,

Eason

Community Support Team _ Eason YU
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
MoodyMas
Level: Powered On

Re: Populated Lookup Field is sometimes not being displayed

Thanks i will be sure to check your suggestion.

 

However, I have actually found that the issue came from filtering the data to only show data Createdby current User().

I set a variable : OnStart: Set(CUser, User().FullName)  and filtered a gallery: Filter(Projects,CreatedBy_Local=CUser).

CreatedBy_Local is a calculated field made = to the lookup 'Created by', this elminates delegation issue.

 

This caused the lookup fields to sometimes not show there default data. I then added a button to refresh data Projects (If the Lookups do not display) which does solve the issue for now.

 

I will try and recreate this and i will post back.

 

Thanks for your help.

MoodyMas
Level: Powered On

Re: Populated Lookup Field is sometimes not being displayed

Hello @v-sheyu-msft,

 

So what I thought would work, has now stopped.

 

I have created a collection and it populates everything correctly.

 

Could you advise what i should do without need to recreate my whole APP? I have recreated with the same entities and it seems the issue is no longer there. However, like my current App it sometimes works and other times not... 

 

I have done some more investigation, if I add the lookup field to the Gallery it shows there, but not in the view form next to it. Other times the gallery also does not show it. I have found a Gallery with no filter or search function shows the lookup fields while the other, with a number of filter and seachs does not show the lookup fields.

 

Thanks in advance.

Highlighted
MoodyMas
Level: Powered On

Re: Populated Lookup Field is sometimes not being displayed

Hello,

 

Apparently it there was a problem within CDS. They believe they have solved the issue.

 

Thanks

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,737)