cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jurix
Level: Powered On

PowerApp Connector to functions returns 200 empty response

I have prepared custom connector to functions besed on postman solutions. THe functions are exposed as API managements with Ocp-Apim-Subscription-Key. the connector is set also with this header security, but when calling function it returns 200 ok with empty results. it seems it uses internal APIM to call our APIM.

I have checked on our APIM side and the calls are successfull. so something must be wrong on translating the response to Powerapps connector tests. 

I have used the example with sentinent text api and did the same. how to track the errors? 

the request goest to: https://europe-001.azure-apim.net/apim/dev.2dewii.2ddg.2dtemplates.5ff671b8f17eca6006.-9e38689026319...

4 REPLIES 4
Community Support Team
Community Support Team

Re: PowerApp Connector to functions returns 200 empty response

Hi @jurix,

Could you please share a bit more about the OpenAPI definition file for your custom connector?

Do you define a proper Resposne part within the OpenAPI definition file (for your custom connector)?

Please check if you have defined a proper Response part within the OpenAPI definition for your custom connector. The standard format of OpenAPI definition file as below:

https://procsi.blob.core.windows.net/docs/SentimentDemo.openapi_definition.json

In addition, please check if your RESTful API has returned a proper result. You could consider take a try to test your RESTful API within Postman, then check if the returned result is empty. If the returned result is empty, I think this issue is related to your RESTful API.

 

More details about customizing connector within PowerApps, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/register-custom-api

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
jurix
Level: Powered On

Re: PowerApp Connector to functions returns 200 empty response

Hi @v-xida-msft

Thank you for some inputs. The point with valid Response part within OpenAPI definition may be right.

However, I have followed this turorial https://docs.microsoft.com/en-us/connectors/custom-connectors/define-postman-collection , and also the one for postman collection create with response saving: https://docs.microsoft.com/en-us/connectors/custom-connectors/create-postman-collection#save-the-req... and then exported to API v1. 

 

Next step was to import this postman collection in PowerApps custom connector. That spoken, I don't know how to check what OpenAPI definition this collection was automatically converted to... Any idea how to check that?

 

The postman sollution was returning correct response btw.

abecerra
Level: Powered On

Re: PowerApp Connector to functions returns 200 empty response

Hello I'm having the same problem. When creating the connector from scratch or from postman

jurix
Level: Powered On

Re: PowerApp Connector to functions returns 200 empty response

Hello @abecerra, if it helps you, we switched from custom connector to database connector (we use sql server). 
the benefit is that it comes with automaic generation of CRUD UI which you may then finetune, so a great help for begginers. 

some drowebacks is that joins are limited, so only usable for simple operations. if you want to make a join 1-many you need to create connecitons to 2 tables and then utilize a lookup. 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,118)