cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Meagan_Longoria
Level: Powered On

PowerApps mobile app not working with parameters?

I created a PowerApp for my company to update project status. I have set it up with a parameter for ProjectStatusID so I can generate the link with Flow creating the appropriate URL to take the project owner directly to the specified project. We want the app to be mobile friendly (and I did use the mobile app layout). When I open the app via a link with parameter in the url with a web browser on my phone, it works fine but the app is very small within the browser window. When I open the app with the Power Apps mobile app, the screen is rendered, but the parameter is not used to select the correct project. Does the mobile app not support parameters? Or is there some workaround or feature I'm missing? 

4 REPLIES 4
PowerApps Staff sarafankit
PowerApps Staff

Re: PowerApps mobile app not working with parameters?

What link format are you using? Don't use the one from the browser address bar but rather use the one from the Details page on web.powerapps.com for your app.

 

It should be something like: 

https://web.powerapps.com/apps/<app-id>?ProjectStatusId=<value>
Highlighted
Meagan_Longoria
Level: Powered On

Re: PowerApps mobile app not working with parameters?

 

Ah, I think I found the issue with the url, but my problem is not resolved. I had & after the ? when it wasn't needed. Now it works about 2/3 of the time when I click my link and choose to open in the mobile app. But every three or four attempts I get an error message that says "The app isn't opening correctly. The app didn't install correctly. Please try again." The latest session ID in the error is 2325dad5-c6ce-4642-a3de-0322e76bd644. 

 

I don't experience this issue when I open my project mgmt app from the menu within the mobile app.  It's only an issue when I select the link and then choose to open it with the mobile app.

 

PowerApps Staff sarafankit
PowerApps Staff

Re: PowerApps mobile app not working with parameters?

Thanks for confirming that the link is working, we will look into the issue around the error you are getting on random tries.

Meagan_Longoria
Level: Powered On

Re: PowerApps mobile app not working with parameters?

Did you have a chance ot look into the error?

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 181 members 5,298 guests
Please welcome our newest community members: