cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Cybersurfer411
Level: Powered On

Powerapps Service Availability/Performance Issues!! - Frowny face, Datasource not found

11/13:

We are constantly facing app crashes and our IT teams are up most of the nights over the last week multiple times with Apps coming up with a "sad face" every few hours over the last one week!

 https://powerusers.microsoft.com/t5/General-Discussion/Powerapps-Errors-Frowny-face-Datasource-not-f...

 Is there any solution in site for these performance issues? or should we recommend our clients not consider this solution at all?!

 We cannot have this maintenance nightmares and constant reboots/refreshes of the App.

 Thanks.

------

Original post:

Hello all,

We developed a "Whiteboard" style display App that is supposed to stay ON on a overhead display & refresh every 5 mins (Gallery refresh set to x5 mins) and we wrote an automated system level scheduled task to reboot the device and auto-login to powerapps every 4 hours to keep the session active. It is currently running on Chrome. We use a on-prem datasource to connect the App using a gateway to a SQL Server. There are less than 5 active users using the App at any given time.

 

The system/bowser running the App is dedicated and has nothing else running on it.

 Do we know how often the Browser needs to refresh or what may be causing the below issues?

 

1. We keep getting a Black screen/frowny face/sad face error once in a while for no reason. (Attached pic)

2. When we open the App to click "edit items" in Gallery to update items, we keep getting "Datasource Not Found" intermittently. There is always a need to let it "sit" (loading) for a while before we can click the ">" arrow to edit the item. I also added a "loading" icon which disappears After the full App's "OnStart" routine is completed and only then edit items but we still face the same issue. We have had to Refresh the App multiple times to be able to hit the arrow to go to next update screen to work!

 blackscreen.JPGdatasource_Error.JPG

We've tried all kinds of options inlcuding using ClearCollect & Refresh(DS) to refresh, logon/off the system to reload browser/device but none of it seems to help and these intermittent issues are causing the App useless as the "Display Board".

 

Is anyone else facing a similar issue? Thanks!

14 REPLIES 14
PowerApps Staff cherie
PowerApps Staff

Re: Powerapps Service Availability/Performance Issues!! - Frowny face, Datasource not found

@Cybersurfer411, I'm sorry to hear about the issues that you are experiencing.

 

Do you think you could provide me with the following information?

 

Session id - https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/get-sessionid

Url of site that you are accessing.

 

Thanks

Cherie 

Highlighted
Cybersurfer411
Level: Powered On

Re: Powerapps Service Availability/Performance Issues!! - Frowny face, Datasource not found

(Updated session info 5.12pm)

 

hi Cheri,

 

The board is hosted at a couple places to test. Does it matter where it is hosted? the errors are the same on all intermittently. We have 2 for the same purpose. One is Display ONLYand other is used to update the first one. We had to have 2 sepearted due to the issues i mentioned. We tried to decouple display and Update activities for better performance.

 

Display App: (1 of 2)

Black Screen/frowny face issue seems to happen frequenrly at nights after 9pm.

Here is the Session ID from Edit App screen: <Pic Attached>Session ID.pngDisplay App Session ID (1 of 2 Apps)

 https://web.powerapps.com/apps/41b032c7-7556-4af6-91c9-51c240ed7903 (Display one thats creating black screen intermittently)

 

Update App:(2 of 2)

Session ID: afb1d55e-8b8d-4cd9-8688-ecae217e0c2d
PowerApps 3.18105.16

https://web.powerapps.com/apps/be8e3430-16fc-4810-9086-5e0945f8e5d3 (2nd App to Edit only and causing DS not found inssues intermittently)

 

 

 

Thanks!

 

PowerApps Staff cherie
PowerApps Staff

Re: Powerapps Service Availability/Performance Issues!! - Frowny face, Datasource not found

@Cybersurfer411, can I confirm my understanding of the issue?

 

You have 2 apps, one just displays the data, and the other allows you to edit the data.

 

The first app that displays the data occasionally has the black screen issue, but not the datasource not found issue?

And the second app that edits the data has the datasource not found issue and not the black screen issue?

 

Both these issues only occur when playing the app (url starts with web.powerapps.com) not editing (url starts with create.powerapps.com)? If it is at all possible to grab the session id that reproduces the issue, it would be most helpful.

 

I have a few things for you to try:

1) Ensure that the delay load setting is enabled in the experimental app settings

2) Ensure the Control property optimization setting is enabled in the experimental app settings

3) If you are using the onstart function, and you are relying on this to populate the data, can you make sure the Use non-blocking OnStart is disabled in the experimental app settings.

Cybersurfer411
Level: Powered On

Re: Powerapps Service Availability/Performance Issues!! - Frowny face, Datasource not found

Hi Cheri,

Thank you for the suggestions. Do we need to re-publish the apps once these changes are made?

 

Also, yes, your understanding of the issue is correct. Both Apps are essentially copies of one another for the most part except for minor differences. Since we started having the listed issues on both Apps, we separated the usage to one for update and one for display. Also, there are occassional memory issues causing the browser to crash. not sure if this is a PA issue though. The session ID's provided were the ones causing issues

 

Thank you!

PowerApps Staff cherie
PowerApps Staff

Re: Powerapps Service Availability/Performance Issues!! - Frowny face, Datasource not found

Yes you will need to republish the apps once you change the settings.

 

Let me know if that helps! We'll take a look at the sessions provided.

Cybersurfer411
Level: Powered On

Re: Powerapps Service Availability/Performance Issues!! - Frowny face, Datasource not found

HI,

 

It looks like the suggestions you had (1) was already checked. (I went through the Experimental settings earlier). I also made configuration changes suggested i.e. (2) and (3) as well and republished both Apps.

 

Another thing to note is that the "black screen" issue seemed so far only to happen at night between 8pm - 8am for the most part. 

 

I will keep an eye out for issues after these changes.

 

Thank you!

Cybersurfer411
Level: Powered On

Re: Powerapps Service Availability/Performance Issues!! - Frowny face, Datasource not found

We just had an issue of the black frowny face again. Here is the session id attached.

Infact the board was running the same App in 2 different places and both had a similar issue around the same time around 3.40pm PST. Thank you.
Cybersurfer411
Level: Powered On

Re: Powerapps Service Availability/Performance Issues!! - Frowny face, Datasource not found

Another App crash just now around 11.30am PST. Session ID attached.App_Error_11152018.pngsessionid_11152018

Cybersurfer411
Level: Powered On

Re: Powerapps Service Availability/Performance Issues!! - Frowny face, Datasource not found

And again at 1335. Attached session id:

This is turing into a nightmare. Should we reverse some of the suggested changes earlier?IMG_04741.jpgSession_ID

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 229 members 5,498 guests
Please welcome our newest community members: