cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Sokg
Level: Powered On

Problem loading gallery from SQL Table

Hello to all,

 

I have a gallery with items property = '[dbo].[ReqHeaders]'

All looks good, but when I save and reopen the gallery shows blank.

Tried to remove the source and add again.

Then gallery is ok.

But when save , publish and reopen gallery is empty again.
Any suggetions???

2 ACCEPTED SOLUTIONS

Accepted Solutions
Community Support Team
Community Support Team

Re: Problem loading gallery from SQL Table

Hi @Sokg ,

Do you mean that the Gallery would display blank when you re-open your published app?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. Please consider turn off the "Explicit column selection" option within Advanced settings of App settings of your app, then re-publish your app, check if the issue is solved.

 

Also please consider save your SQL Table records into a Collection, then use the Collection as data source in your app instead of original SQL Table data source. I have made a test on my side, please take a try with the following workaround:

Set the OnStart property of the App control to following:

ClearCollect(RecordsCollection, '[dbo].[ReqHeaders]')

Set the Items property of the Gallery to following:

RecordsCollection

Note: Please make sure set the "Data row limits for Non-delegable queries" option to maximum value -- 2000 within Advanced settings of App settings of your app.

 

In addition, if the amount of your SQL Table records is more than 2000, you should consider bulk-load your SQL Table records into multiple individual collections, then merge the multiple collections into a single one collection. After that, use the merged collection as data source in your app.

Please check and see if the alternative solution mentioned within the following thread would help in your scenario:

https://powerusers.microsoft.com/t5/General-Discussion/Pulling-in-large-ish-SQL-tables/m-p/243777#M7...

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

sokgpbre
Level: Power Up

Re: Problem loading gallery from SQL Table

Hi @v-xida-msft 

 

Sorry it was my mistake.

Somehow I manage to set visible property to all labels in my gallery to false.

That was the problem.

Thanks for your reply.

View solution in original post

3 REPLIES 3
Community Support Team
Community Support Team

Re: Problem loading gallery from SQL Table

Hi @Sokg ,

Do you mean that the Gallery would display blank when you re-open your published app?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. Please consider turn off the "Explicit column selection" option within Advanced settings of App settings of your app, then re-publish your app, check if the issue is solved.

 

Also please consider save your SQL Table records into a Collection, then use the Collection as data source in your app instead of original SQL Table data source. I have made a test on my side, please take a try with the following workaround:

Set the OnStart property of the App control to following:

ClearCollect(RecordsCollection, '[dbo].[ReqHeaders]')

Set the Items property of the Gallery to following:

RecordsCollection

Note: Please make sure set the "Data row limits for Non-delegable queries" option to maximum value -- 2000 within Advanced settings of App settings of your app.

 

In addition, if the amount of your SQL Table records is more than 2000, you should consider bulk-load your SQL Table records into multiple individual collections, then merge the multiple collections into a single one collection. After that, use the merged collection as data source in your app.

Please check and see if the alternative solution mentioned within the following thread would help in your scenario:

https://powerusers.microsoft.com/t5/General-Discussion/Pulling-in-large-ish-SQL-tables/m-p/243777#M7...

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

sokgpbre
Level: Power Up

Re: Problem loading gallery from SQL Table

Hi @v-xida-msft 

 

Sorry it was my mistake.

Somehow I manage to set visible property to all labels in my gallery to false.

That was the problem.

Thanks for your reply.

View solution in original post

Community Support Team
Community Support Team

Re: Problem loading gallery from SQL Table

Hi @sokgpbre ,

Have you solved your problem?

 

If you have solved your problem, please go ahead to click "Accept as Solution" to identify this thread has been solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,396)