cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
React365-Chris
Level: Powered On

Problem with People Picker column no results, no save

Hello!

 

As of today my SharePoint people picker columns are not resolving and showing user choices once the app is published. The app works fine when using the player inside of the web editor but once the app is published the picker control does not work. I tried delete and adding the card back and also deleted the new form and added a new copy with no change. 

 

1. In PowerApp editor player (works as expected)

Capture1.PNG

In Chrome after publish:

Capture2.PNGName not resolving after publishCapture3.PNGSharepoint column settings (not multi select)

 

 

7 REPLIES 7
Community Support Team
Community Support Team

Re: Problem with People Picker column no results, no save

Hi @React365-Chris,

 

 

I have tested it from my side.

The combo box works per my testing.

The only difference is that when using it under App in Web mode, it will only show results after text has been entered.

 

Besides, take a try with:

Dev

 

See if this would make any difference.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
React365-Chris
Level: Powered On

Re: Problem with People Picker column no results, no save

Hi Michael,


Thanks for the reply but we are way beyond that in our troubleshooting. I have created a test application on the tenancy from a SharePoint list with just two columns; Title and TestUser (user column, same settings as last).

 

Again, using the PowerApps Studio (f5 or play) and the people picker column works fine. Once I publish the app I do not get results and the field changes. In the test case I recieved unexpected results which differ yet (in image).

 

Note, this is for a company that has federated AD to Azure AD. Are there any known issues there? I have created and have several PowerApps in production today and never have I seen this before.

 

How can I escallate for support?Capture4.PNG

React365-Chris
Level: Powered On

Re: Problem with People Picker column no results, no save

I watched the traffic on Fiddler for all examples. I see that when using the player (from studio) I get a JSON value back for the user after the call is made when typing. On the published version there is no JSON value sent back to powerapps, thus nothing to display.

 

 

React365-Chris
Level: Powered On

Re: Problem with People Picker column no results, no save

ok- after more digging I found a consistent issue. If you change anything in the column settings, say from searching just people to search people and groups as an example, the data card for that listcolumn is broken. If you even change the setting back it remains broken.

 

Can anyone replicate this to confirm the bug?

Community Support Team
Community Support Team

Re: Problem with People Picker column no results, no save

Hi @React365-Chris,

 

I am currently using the free trials for testing, and the SharePoint online list works.

This may not fit your scenaro.

If you would like to create a Support ticket, then please try:

https://powerapps.microsoft.com/en-us/support/

 

At the bottom of the page above.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Re: Problem with People Picker column no results, no save

Hi @React365-Chris

 

Do you have "locked" this card so it runs in default mode? This default mode should prevent it from being broken.

 

I have tried to replicate your scenario, and I was not able. Everything works for me.

 

lauriewheeler
Level: Powered On

Re: Problem with People Picker column no results, no save

I've got the same problem.  I have two people columns, but I only modified one of them in SharePoint, but in the app, I removed the old column, refreshed the data sources, added the column back in, saved and published and the behavior is the same for both my people columns.  works in Preview, but not published.  

So are we saying here?  That I have to use alternate custom data cards with combo boxes that pull from Office365users to populate my SharePoint columns? eeewwhhh ugly. 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,043)