cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bboardman
Level: Powered On

Problem with edit form and 'two-option' datatype field

As of today, I cannot correctly add a 'two-option' field to an edit form using a newly created PowerApp.  To be more specific, when adding this type of field before it would come in as 'boolean' using a toggle control.  Now, it comes in as a 'complex' datatype using a dropdown control.  Why?  If I edit an older app and add a new form it comes in correctly.  This only seems to happen on a brand new application.

 

Was there a recent update that changed the way this works?  If so, then how do I get my fields to come in as 'boolean' and not 'complex'?

 

5 REPLIES 5
Community Support Team
Community Support Team

Re: Problem with edit form and 'two-option' datatype field

Hi @bboardman,

Could you please share a bit more about the 'two-option' field that you mentioned? Is it a Yes/No type column or a Choice type column in your SP list data source?

If the 'two-option' field that you mentioned is a Yes/No type column in a SP list, I have made a test on my side, and don't have the issue that you mentioned. The Yes/No type column would come as 'Boolean' using a Toggle control rather than a Dropdown/Combo Box control.

 

If the 'two-option' field that you mentioned is a Choice type column, in default, this field would come as 'Complex' type using Combo Box control.

 

Please take a try to re-create a new app based on your SP list data source, then check if the issue is solved.

In addition, you could also consider take a try to convert the Combo Box/Dropdown control into the Toggle control within the 'two-option' field Data card.

You could remove the Combo Box/Dropdown control from the 'two-option' field Data card in your Edit form, then add a Toggle control within it. After that, bind the Toggle control with the 'two-option' field in your SP list.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
bboardman
Level: Powered On

Re: Problem with edit form and 'two-option' datatype field

thanks for your reply.  believe it or not, it is now working and coming in to the form okay?  i did not change anything and am using the same 'new' app that i created yesterday...so frustrating!

 

anyways, this is what i was seeing.  the picture with the 'boolean' data type is correct (as of today).  the picture with the 'complex' data type was what i was orginally seeing.  thanks again for your reply!!  😄

 

field.boolean.pngfield.complex.png

 

bboardman
Level: Powered On

Re: Problem with edit form and 'two-option' datatype field

so, my mistake...it is still not working.  the app i tried was a copy (save as) of an older app that was working.  i created a new app and am still having the same issue.  i tried to change the control type by inserting a toggle control to the data card but it won't let me as it just adds it to the screen (not the form or datacard).  Also, i am unable to delete anything under the datacard.

 

field.options.pngfield.cannot.delete.control.pngfield.insert.control.pngfield.new.control.png

Community Support Team
Community Support Team

Re: Problem with edit form and 'two-option' datatype field

Hi @bboardman,

Currently, I could not reproduce your issue on my side.

As an alternative solution, you could consider take a try to remove the Combo Box control within the corresponding Data card, and then add a Toggle control within it.

If you want to add controls into corresponding Data card, or remove controls from it, you must unlock the corresponding Data card within the Edit form firstly.

Please check the attached GIF screenshot for more details:

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
bboardman
Level: Powered On

Re: Problem with edit form and 'two-option' datatype field

ugh, sorry....i forgot you have to unlock the properties first.  okay, i'm able to delete/add the control now but the bigger issue is why is it happening now and only with new apps?  i had a co-worker try it as well, it is happening for him too.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 351 members 5,136 guests
Please welcome our newest community members: