cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
DominikK
Level: Powered On

Problem with exporting app

Hi everyone,

 

I want to move my app to isolated environment but i can't export it.

Export package tab shows me error "The caller with object id 'xxxx' does not have permission for connection 'xxx' under Api 'shared_logicflows'.". 

I tried to remove all unused flows and data sources but it doesn't fix anything.

4 REPLIES 4
Community Support Team
Community Support Team

Re: Problem with exporting app

Hi @DominikK ,

 

According to the documentation:

https://powerapps.microsoft.com/en-us/blog/powerapps-packaging/

If an app depends on a custom connector we do not currently support exporting the connector as a part of the package.

 

If you have an app that relies on a custom connector, your only current option is to manually re-create or update the connector in your target environment and select that connector when you import the package.

 

Check if above is the cause of your issue.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
DominikK
Level: Powered On

Re: Problem with exporting app

Hey @v-monli-msft ,

 

Thank you for the answer, i read that my sql connector may not packaged. But the problem is I still can't export my app, even without this resource. After i click "export package" i get blank page with gray export button.

Community Support Team
Community Support Team

Re: Problem with exporting app

Hi @DominikK ,

 

Is SQL connector the only data source that included in your exported app? If so, please try to test with a new app.

 

If not, what are the other ones? 

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
DominikK
Level: Powered On

Re: Problem with exporting app

@v-monli-msft 

Hi,

yes, sql connector is the only connector in the app. I had saved my app on storage, opened it on new blank app, removed all data sources / connectors and problem still exists. 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,600)