cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jonz44
Level: Powered On

Profile Change of App Owner

 

I have created an app which connects to SharePoint list on a team site. The app has buttons on a dashboard and access to each button is restricted using a access string read from the a user SharePoint list.

 

I recently changed my company within the organization and the admin have done some profile change to my O365 user account to match my new position. The app stop recognizing users, except users set as owners, and since the users are not recognized, the access control for the buttons does not work because the lookup() set up to read the SharePoint list does not work.

 

There are features in the app open for all like gallery displays are working without issues.

Can someone be able to through some light as to what could the issue?

 

2 REPLIES 2
Community Support Team
Community Support Team

Re: Profile Change of App Owner

Hi @jonz44,

I think this issue is related to the changing of the profile of your O365 user account. 

Currently, if you want to fix this issue, you could consider take a try to re-create a new connection to all data sources added within your app, then try your app again, check if the issue is solved.

If the issue still exists, please consider take a try to re-create your app, check if the issue still exists.

In addition, you need also to change the corresponding access string within your user SharePoint list for your O365 users (whose profile has been changed).

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
jonz44
Level: Powered On

Re: Profile Change of App Owner

Hi Kris,

 

Took a while to give my feedback as I was trying our various things as suggested. I can say that most part of app is working. 

 

I am using the value from user().FullName to give selective access to various buttons on the app. As I see now for some users the value is picked up and for some it does not (or may taking a lot of time). The current user name is displayed on the opening screen or dashboard. For users who are not able to access the buttons, the current user name is not displayed, which means the User().fullname function is not working properly.

 

Any thing to do with the User Connection? 

 

Does it ring any bell?  

 

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

Top Kudoed Authors
Users Online
Currently online: 275 members 5,569 guests
Please welcome our newest community members: