cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
pmcgurn01
Level: Powered On

Radio buttons don't display tooltips when part of a Gallery in DisplayMode.View

I have an app I built where I have a Gallery that includes data type where a radio button is used to display it.  If I set the DisplayMode to Edit, the tooltips on the radio button work as expected.  If I set it to View, the tooltips don't work.  This is not an issue with radio buttons in View mode on Forms, only when they are included in a view-only Gallery control.  I'm sure I "could" hack this with a label instead, but figured I'd report a bug before I resort to reworking this.

 

Attaching screenshots.  "ACT" is short for "Active".  I use "ACT" as the "true" property of the radio buton to save screen real estate.

inviewmode.pngIn view mode

 

ineditmode.pngIn edit mode

1 ACCEPTED SOLUTION

Accepted Solutions
pmcgurn01
Level: Powered On

Re: Radio buttons don't display tooltips when part of a Gallery in DisplayMode.View

I didn't like the look of the Disabled view state, so I ended up converting this to a Label instead, and setting the Color and Tooltip properties based on ThisItem.Fieldname instead.

View solution in original post

2 REPLIES 2
Community Support Team
Community Support Team

Re: Radio buttons don't display tooltips when part of a Gallery in DisplayMode.View

Hi @pmcgurn01 ,

I've made a similar test and found that what you mentioned is right.

When the gallery is edit mode, the toggle's tooltips will display.

When the gallery is view mode, the toggle's tooltps will not display.

I also tried edit form.

When the form is edit mode, the toggle's tooltips will display.

When the form is view mode, the toggle's tooltps will not display.

So I've searched this property and found that:

Tooltip – Explanatory text that appears when the user hovers over a control.

It means that the tooltips will display next to the control.

Please notice that the tooltips display next to the control , not the value.10245.png

 

However, when the gallery's mode change to view, the toogle's button disappear, it will just show the value like a text.

As alternative way, I suggest you not set the gallery's mode to view, set it to edit.

Set the toggle's mode to Disabled.

In this way, the toogle button will not disappear, so the tooltips will display and others could not edit too.

 

10246.png

 

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
pmcgurn01
Level: Powered On

Re: Radio buttons don't display tooltips when part of a Gallery in DisplayMode.View

I didn't like the look of the Disabled view state, so I ended up converting this to a Label instead, and setting the Color and Tooltip properties based on ThisItem.Fieldname instead.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 169 members 5,736 guests
Recent signins:
Please welcome our newest community members: