cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Liam
Level: Powered On

Saving Attachment and Patching Item - ETAG Error

Hi

we have a powerapp that allows the user to fill out some details, add some attachments then save to a sharepoint list

as of today I have had reports this no longer works. Forms can still be saved without attachments.

 

The last form with attachments saved in this list is from the 13th of April there have been many more since then without attachments. So this issue occured between now and then.

 

There have been no changes to the powerapp. The user fills out a number of details in custom fields etc. The attachments are saved via SubmitForm then the FormName.LastSubmit.Id is used to select the record to patch.

 

The message we now get is:

Conflicts exist with changes on the server, please reload. Server Response: ETAG mismatch

 

 

I can create a new powerapp point it to a test list and recreate this issue but it did work before. Has there been any updates to SP or PowerApps that may have caused this to stop working or could this be a temporery issue due to something ongoing in office 365? 

 

Edit - Attached screenshot of recreated app save function and error msg (you can also see the correct Id is coming back in the Label displaying LastSubm it.ID) : 13 I have also tried moving the patch to the forms Onsuccess

 

8 REPLIES 8
Anonymous
Not applicable

Re: Saving Attachment and Patching Item - ETAG Error

Did you manage to resolve this issue? 

Liam
Level: Powered On

Re: Saving Attachment and Patching Item - ETAG Error

I could not resolve the problem, I do need to know what the cuase is (if it was an update to PowerApps or SharePoint) so that I can explain why it stopped working but i changed the way the form worked to get around the issue

 

Anonymous
Not applicable

Re: Saving Attachment and Patching Item - ETAG Error

Could you tell me what did you do to get around the issue as I'm having the same issue? Thanks

Liam
Level: Powered On

Re: Saving Attachment and Patching Item - ETAG Error

In my situation the form has a bunch of custom fields and logic at the top. Then a form control underneath that pointed to a SharePoint list, with the only field being used the attachments field.

the attachments were saving through the SubmitForm. but the patch immeditaly after the submit that used the Forms LastSubmit.ID (to save the values created in the custom fields) stared throwing the ETAG error.

 

So i was able to just set all these values i was patching onto the record to be default values for all the other form fields and kept them not visible. So everything was submited by the SubmitForm Function

Highlighted
Anonymous
Not applicable

Re: Saving Attachment and Patching Item - ETAG Error

Thank you, I will try that.

kelvinyeong
Level: Powered On

Re: Saving Attachment and Patching Item - ETAG Error

Hi Liam, do you mind to provide how the code look like? thanks

 

PowerApps Staff anees
PowerApps Staff

Re: Saving Attachment and Patching Item - ETAG Error

We are working on a fix. In the meantime please see if the solution mentioned here unblocks you.

 

https://powerusers.microsoft.com/t5/General-Discussion/Server-Response-ETAG-mismatch-Conflicts-exist...

 

Thanks

Anees

 

Muzammil
Level: Powered On

Re: Saving Attachment and Patching Item - ETAG Error

Your SharePoint list fields type should be the same type as used in PowerApps fields type. i.e. if using the dropdown in PowerApps, you need to make sure you are using Choice in SharePoint list for the same field.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,794)