cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tscott07
Level: Powered On

Screen not appearing as blank

i embedded my powerapp in my sharepoint page. I only have an edit screen. I would like for the form to appear blank then return to blank after save. 

 

Currently form populates the first item in the SharePoint list. I am not sure if I need a formula in the Onstart, or in the on visible of the screen.  

 

4 REPLIES 4
Super User
Super User

Re: Screen not appearing as blank

@tscott
To make the form appear blank put this code in your OnVisible property for the screen.

NewForm(your_form_name);

You can also put that code in the OnSelect property of the button used to Submit the form.

—-
Please Accept as Solution if this post answered your question so others can find it more quickly. If you found this post helpful consider giving it a Thumbs Up.
Highlighted
tscott07
Level: Powered On

Re: Screen not appearing as blank

gescreen on visible code is If(varFormViewMode = "new", NewForm(EditForm3),EditForm(EditForm3))

I have to be able to view the item on edit but i cannot get that part to work either. I figure the issue is the onVisible formula. 

Super User
Super User

Re: Screen not appearing as blank

Best to solve these problems one at a time.

 

Let’s start by solving the problem to clear the form for new entries. I like your current formula in OnVisible.  Where have you defined the global variable varFormViewMode?  How does it get set to "new"?  Are you sure the value is "new" when you want to work with a blank form?

 

Then, you'll want to look into the Default property of each DataCard on your form?  They should all be set to blank (i mean clear the field not Blank()) if you want to see no values on the form.

Community Support Team
Community Support Team

Re: Screen not appearing as blank

Hi @tscott07 ,

Do you want your Edit form to be Blank after your submit your Edit form data?

Could you please share a bit more about the Item property of the Edit form?

Have you set the DefaultMode property of the Edit form to FormMode.Edit?

 

I have made a test on my side, please consider take a try with the following workaround:

Set the DefaultMode property of the Edit form to following:

FormMode.New

Please take a try with above solution, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (4,753)