cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Server Response: Principal user is missing prvRead[Entity] privilege - data doesn't load

I've added new users to the PowerApp and while they have the correct permissions enabled (i.e., they're designated as a CDS user in Dynamics), when the user loads the PowerApp they encounter the message: "An error occurred on the server. Server Response: Principal user (Id=<userid>, type=8, accessMode=1, roleCount=2) is missing prvReadAccount privilege (Id=<id>)" and nothing loads in the app. The error messages flash frequently and cycle through all of the other entities, both standard (e.g., Account, Contact) and custom and then eventually stop, but still no data loads. As you can see in the attached screenshot, users are able to view the structure of the app but there's just no data present. Other users have no problems, despite having the exact same roles and permissions. I've tried revoking then regranting privileges, as well as designating the new users as System Administrators, but nothing works. Is this a known issue and how can I fix it? powerapp cds privileges error.PNG

4 REPLIES 4
Community Support Team
Community Support Team

Re: Server Response: Principal user is missing prvRead[Entity] privilege - data doesn't load

Hi @Anonymous,

Based on the error message that you provided, I think the end user has not been assigned a proper permission to access your CDS Entity.

When sharing an app which connects to a CDS Entity with other users, you must also ensure that the users who will run it have the appropriate permissions for the entity. You must firstly define a security role which has proper permission to perform tasks such as creating, reading, writing, and/or deleting within the relevant entity, and then assign the security role to the other users.

More details about managing CDS Entity permission, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/share-app#manage-entity-permissions

Please check and see if the following blog would help in your scenario:

https://community.dynamics.com/crm/b/crminogic/archive/2016/02/19/error-principal-user-is-missing-prvreadaccount-privilege-resolved

Please check if you have assigned proper security role which has enough permission to perform tasks within the specific entity to the other users.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Re: Server Response: Principal user is missing prvRead[Entity] privilege - data doesn't load

Hi Kris,

 

I do have the proper security roles assigned. All of the users have the same roles but only some are getting this error message. I have no idea why because they're identical. I think this may be a bug in PowerApps. 

Highlighted
Simmo86
Level: Powered On

Re: Server Response: Principal user is missing prvRead[Entity] privilege - data doesn't load

Hi, 

 

Did you ever resolve this? I have the same issue and have gone through all the help texts and assigned all roles etc. but get exactly what you get. 

 

Thanks,

 

Alex

Som_Maganti
Level: Power Up

Re: Server Response: Principal user is missing prvRead[Entity] privilege - data doesn't load

Can anyone post if this is resolved - getting a similar error and permissions seem enabled

Thanks

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (4,437)