cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tommyly
Level 8

SharePoint List Column Not Appearing in PowerApps per PowerApps Data Refresh

So the title is sort of confusing, so please read the details below:

 

For this issue, I am using SharePoint Online. There are numerous ways to create new columns (the following is probably not an exhaustive list):

  1. Go to SharePoint Custom List Settings and add column
  2. On the list view page, click "+ Add column"
  3. On the Quick Edit list view page, click the "+" sign (which appears to be shorthand for + Add column)

 

Example Scenario: I create a PowerApps called "MyPuppiesApp", which allows users to append records of puppies to my PuppyList SharePoint custom list. I later decide that I want to include "Furry" as a Boolean field. If I add it using listed method (above) 1 or 2, a PowerApps refresh will work as designed. If I use listed method 3 (adding column via Quick Edit view), PowerApps will never, ever recognize it, no matter how many times I refresh PowerApps or whether I exit Quick Edit view, subsequently refresh my browser after exiting Quick View, or populate that field with data.

 

In fact, in an effort to test, I've deliberately and knowingly created a column using method 3 and then subsequently created columns using methods 1 and 2, and a PowerApps data refresh will update my data source with the columns from methods 1 and 2, but the column from method 3 remains nonexistent in PowerApps--even though it was created (albeit in Quick View) chronologically before the other additional columns.

 

I'm not sure if this is isolated to me, but maybe some users can try this to confirm. Thanks.

5 REPLIES 5
Community Support Team
Community Support Team

Re: SharePoint List Column Not Appearing in PowerApps per PowerApps Data Refresh

Hi @tommyly,

 

Do you mean the only option 3 is not available to see the changes in PowerApps?

 

Instead of Data source refresh, have you tried to remove the SharePoint list data source, and then add it again?

Add another data source

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
egallis
Level 10

Re: SharePoint List Column Not Appearing in PowerApps per PowerApps Data Refresh

Hi @tommyly,

 

I was able to create columns using method no 3 and retreive them in PowerApps using the Refresh button.

 

Here is my scenario:

  1. I created a new list called Test
  2. I customized the list's form in PowerApps
  3. I published the customized form from PowerApps
  4. In SharePoint, I activated the QuickEdit mode on the list
  5. I created a new text column called Col1
  6. I entered some data
  7. I quit the QuickEdit mode
  8. I went back to my PowerApps tab and clicked the Refresh button
  9. The column Col1 appeared in the list of available columns for the Test list datasource

Note: I took a glance at the columns itself in the list properties and noticed that column names are based on a 4-letters random auto-generated code (my Col1 column internal name was rzbl)... strange... why not...

 

What is the type of column you create using method no 3?

tommyly
Level 8

Re: SharePoint List Column Not Appearing in PowerApps per PowerApps Data Refresh

Yes, I tried tried removing the dataset (linked to SharePoint Online custom list) and then adding it again. The column remains invisible. Every other column created every other way is visible for me. Anyhow, if nobody else is experiencing this glitch, then maybe it's isolated to me or my specific environment.

tommyly
Level 8

Re: SharePoint List Column Not Appearing in PowerApps per PowerApps Data Refresh




@egallis wrote:

Hi @tommyly,

 

I was able to create columns using method no 3 and retreive them in PowerApps using the Refresh button.

 

Note: I took a glance at the columns itself in the list properties and noticed that column names are based on a 4-letters random auto-generated code (my Col1 column internal name was rzbl)... strange... why not...

 

What is the type of column you create using method no 3?


I created text (for method 3). If it's working for you then maybe it's isolated to me. I'm not sure. I'm using SharePoint Online as well, so it shouldn't have anything to do with my network environment. I don't know anything about the auto-generated code, but possibly that is affecting this?

 

Anyhow, there are 2 other ways of creating columns, so it's not like this is a showstopper. I just thought I'd point it out as a possible glitch.

bvcitro
Level: Powered On

Re: SharePoint List Column Not Appearing in PowerApps per PowerApps Data Refresh

I'm experiencing this same issue. Arg.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (3,778)