cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kvanstaen
Level: Powered On

SharePoint list connection no refreshing

Hi,

Been relatively new to PowerApps, but made lots of progress thnks to this forum.  However, struggling to find the solution to my latest problem.

My app reads and writes data from the SharePoint list.  For the last week all worked perfectly reading and updating the data.

Then 2 days ago I had to delete some of my columns in the SharePoint list and added some new ones.

Since then, every time I start PowerApps it has little warning symbols for some fields which I changed, but the new fields I added are not available.  Similarly, when using the app on a mobile, the new data does not come through.

When I edit the app online and refresh the connection, everything gets updated, the warning symbols disappear, and the data from new columns comes through.  Unfortunately I can't seem to refresh the connection in the iOS app.

After having refreshed the connection, I have saved the app countless times, but when I open the app again the next time, it has lost the connection to the updated SharePoint list again...

I have tried to add Update(Source) to a button on the homepage of the app, but without any success.

Any other suggestions which would save me having to build the app again from scratch?

Many thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Rob_CTL
Level: Powered On

Re: SharePoint list connection no refreshing

Deleting the data source from within the app does fix the issue, not ideal but it is easy than re-creating the app. 

View solution in original post

25 REPLIES 25
Community Support Team
Community Support Team

Re: SharePoint list connection no refreshing

Hi kvanstaen,

 

Thanks for feedback.

 

I have reproduced this issue on my side.

 

I am trying to report this issue on my side and I will back to you once I got any response.

 

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
lmazzoni
Level: Powered On

Re: SharePoint list connection no refreshing

Hi,

I'm experiencing the same problem with Common Data Service.
The refresh in edit mode is only temporary (it needs to be done every time) and there is no way to do it in the app.

Rob_CTL
Level: Powered On

Re: SharePoint list connection no refreshing

Same issue here since adding two new columns.

Highlighted
PowerApps Staff sarafankit
PowerApps Staff

Re: SharePoint list connection no refreshing

Thanks for reporting this, we are actively investigating this.

 

A suggested workaround is to remove the data sources from your app and add it again. It should maintain all your data bindings.

Microsoft Employee

Re: SharePoint list connection no refreshing

Hi we're loooking into this issue, if you can provide a session Id (Menu->Session Details) that would help us with diagnosing your issue further.

 

Thanks
Garry Mc-MSFT

 

kvanstaen
Level: Powered On

Re: SharePoint list connection no refreshing

Sorry, as I thought it was me having done something wrong, I ended up re-creating the app from scratch and it solved the issue.  Subsequently I deleted the faulty one.  But hopefully one of the other people reporting the issue can provide session ID details.

I'm sure the efforts to get this resolved won't be wasted, as I'm a newbie to SharePoint lists and PowerApps, and can imagine very soon I may have to delete/add columns, so hopefully by then the issue will be fixed.

PowerApps Staff sarafankit
PowerApps Staff

Re: SharePoint list connection no refreshing

Thanks for your understanding, we have identified the issue and are fixing it. We should be able to roll out a fix in about 2 weeks.

Rob_CTL
Level: Powered On

Re: SharePoint list connection no refreshing

Thanks Ankit, removing and re-adding the data connection fixed the issue

 

Rob

 

Community Support Team
Community Support Team

Re: SharePoint list connection no refreshing

Hi kvanstaen,

 

I test this issue again on my side, seems that it has been fixed.

 

When I open the app again, the newly added columns can be refreshed automatically.


Please try it on your side and let me know if it is working for you now.


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 223 members 5,515 guests
Please welcome our newest community members: