cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helen_BB
Level: Powered On

Sharepoint Choice field error

Hello wondering if anyone else is having a similar issue.

 

i have created a form based on a sharepoint list  - pretty simple.

However, everytime i go into to edit my app after saving or publishing i always have Red errors on every single sharepoint choice field. 

I resolve it by coping the formula and pasting the exact same thing back into the field if i do not do this however the field does not work when i play the app does anyone know why this would be happening?

 

images in attachments.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Rebetcha
Level 10

Re: Sharepoint Choice field error

Hi @Helen_BB ,

 

I sometimes run into this issue as well. Usually refreshing the data source fixes the issue for me. 

Go to View > Data sources, click on the ellipses behind the SharePoint data source of your list and select Refresh.

Hopefully this solves you issue. RefreshData.png

View solution in original post

4 REPLIES 4
Highlighted
Rebetcha
Level 10

Re: Sharepoint Choice field error

Hi @Helen_BB ,

 

I sometimes run into this issue as well. Usually refreshing the data source fixes the issue for me. 

Go to View > Data sources, click on the ellipses behind the SharePoint data source of your list and select Refresh.

Hopefully this solves you issue. RefreshData.png

View solution in original post

Helen_BB
Level: Powered On

Re: Sharepoint Choice field error

Thanks @Rebetcha that also works 🙂

 

it would be nice to know what causes the issue.

 

glad to know its not just me

 

thanks

Rebetcha
Level 10

Re: Sharepoint Choice field error

I think the issue comes from some delay in getting data from the data source. The issue seems to have increased since a couple of weeks. Hopefully the team PowerApps team will look into this.
JWhited
Level: Power Up

Re: Sharepoint Choice field error

I had a similar problem; no red X's, but anytime I added a field to an existing form all the existing choice and peoplepicker fields would not fill. 

For a while I would remove and re-add all affected fields and that would work.

However, doing a data source refresh twice in a row like you specified worked.

Buggy...

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

Top Kudoed Authors
Users Online
Currently online: 273 members 5,342 guests
Please welcome our newest community members: