cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
VitorSouza
Level: Powered On

Slow Rendering

Hello Engineers of PowerAPPS,

 

The same APP for which I reported the problem of boot time, reported another problem related to slow rendering.

When loading records from a database table using the "Gallery" component, I wait for the data to be loaded completely. Subsequent to navigating the records (scroll up or down) rendering appears to be lost, and after a few seconds, around 5, the data is again visible.

 

I have attached two photos, the first photo with the data fully loaded and the second photo where I make the navigation (sliding the screen up or down) and the information loaded is lost, leaving the screen blank until after a few seconds, according to The data is displayed again.

 

My app ID is "f8e21f77-ad2d-15c3-addc-f0bec113fd33".

 

Thanks for your attention and I look forward to guidance on how to solve the problem.

 

Screenshot_20170523-080915.jpgScreenshot_20170523-080942.jpg

 

Vitor

9 REPLIES 9
Community Support Team
Community Support Team

Re: Slow Rendering

Hi @VitorSouza,

 

Thanks for reporting this.

Does this issue occurs with in PowerApps studio in web, or PowerApps studio Desktop version?

Apps under PowerApps would keep the App related, like the controls, formula and the screens stuffs stored at the cloud side, once downloaded, it will kepp a local copy.

For Data source, Apps would use the corresponding connection to query the Data source side once there is a requirements configured within the apps.

I think the slow performance issue should be caused by the Data source query.

Please take a try to hold the needed data in a local collection, see if that would make it better.

Create and update a collection in your App

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
VitorSouza
Level: Powered On

Re: Slow Rendering

Hello Michel,
Even creating the collections instead of querying the data online in the database, the problem occurs.
Currently the APP for the features that are most consulted by the users were created collections in order to try to mitigate the problem that I reported. However, that did not solve the problem.
Is there any other solution?
If you want, I can send a video highlighting the problem, which only occurs when using the APP via mobile. Through the browser this problem does not occur.

I wait for return.
Thank you.
Vitor

VitorSouza
Level: Powered On

Re: Slow Rendering

Good Morning.
Any return?

VitorSouza
Level: Powered On

Re: Slow Rendering

Good Morning.
Any return?

VitorSouza
Level: Powered On

Re: Slow Rendering

Good Morning PowerApps Engineers
Any return?

I'm waiting for an answer to the reported problem for almost 1 month.
Thanks.

VitorSouza
Level: Powered On

Re: Slow Rendering

Good Morning PowerApps Engineers, any return?

I'm waiting for an answer to the reported problem for almost 1 month.
Thanks.

Community Support Team
Community Support Team

Re: Slow Rendering

Hi @VitorSouza,

 

Apologize for the late response.

Staff AndyPennell is following on your another thread.

I think there should be changes which has been made to improve your scenario, but the improvements may not be scheduled in this updates.

For the workaround, check this thread to generate the collection, then use the generated collection under the items property instead of the data source.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
VitorSouza
Level: Powered On

Re: Slow Rendering

Hello good day.
As I mentioned in my previous comment, I use COLLECT, but that did not solve the problem.
My table contains 13 (thirteen) records, and yet the problem I reported in the initial comment on this topic occurs.

Even if I do not use "COLLECT" the problem persists, ie, sliding the screen after loading the data, both up and down, the records are lost and only after a few seconds do they appear.

Do you have any other suggestions for a solution?

Thank you for your attention.
Vitor

Sijts
Level 8

Re: Slow Rendering

I'm experiencing the same issues and tried the help mentioned so far.

 

To give an example, using the webversion for the app (not editor, but user experience).

Network wise i have glassfiber speed 500 up and down, use laptop is a surface laptop2 i7 (1 week old), browser chrome.

I'm have a Local collection of hunderd some records.

If i use a gallery, it will be painfully slow, rendering everytime i scroll down will take 5 seconds.

!!But!! if i use a table to show the same amount of data, it renders instantly when scrolling.

 

please help 🙂

 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 443 members 6,489 guests
Please welcome our newest community members: