cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WillyD44
Level 8

Stuck getting data with SharePoint List as Data Source

OVERVIEW

I'm having what I'd consider to be major issues with PowerApps. When using a SharePoint online list as my data source, I cannot create a 2nd screen (net new or by duplicating my first screen) save and publish my app and then use the appThe app loads the first screen, but without fail, will not load the 2nd screen.  It gets stuck with a generic message "Getting your data". Stuck meaning...it never gets my data.  Seems I'm not alone.  

 

https://techcommunity.microsoft.com/t5/PowerApps-Flow/PowerApp-forms-get-stuck-on-quot-Getting-your-...

 

https://powerusers.microsoft.com/t5/General-Discussion/PowerApps-SharePoint-List-Update-Issues-Edit-...   This is the most distrubing one as the user was having issues just last month and microsoft staff was asking for session ids.  

 

https://powerusers.microsoft.com/t5/General-Discussion/quot-Getting-your-data-quot/td-p/156160

 

APP DETAILS

I created this app by first creating my SharePoint list.  Then I chose the Ribbon option under the PowerApps dropdown control entitled Customize forms.  

 

CustomizeForms.png

 

 

My original list had about 20 fileds (mix of choice, text, multiline of text, etc.) and was built in my client's production environment.  The app failed there.  Today, Saturday morning, I'm back at it in a demo environment (fully licensed Enterprise O365 environment).  I've tried several more times, each time, slimming down and dumming down my form to try and isolate the issue.  I'll share details of my last test as it is the simplest form I've created, still throws the "Getting your data" error when I try and navigate to a 2nd screen and should be the easiest to troubleshoot. 

 

Here we go...

 

SCREEN1 

As you can see this is a very simple screen.  This is the screen that PowerApps created for me when I first created my app.  I added the Next icon with OnSelect property value to move it to screen 2.  Screen 2 was created as a net new screen, however; I've tried the Duplicate screen functionality to no avail. 

Screen1-PowerApps.png

 

 

WHEN TRYING TO NAVIGATE TO SCREEN 2

This is the error everybody is getting in the articles linked above. 

Screen2-PowerApps.png

MY POWERAPP IN THE EDITING CANVAS PART 1

Do not let the Item propery value fool you.  It may NOT even be the issue, but some of the users in the above posts mentioned it, so I thought I'd at least show the 2 different values I've set it to. 

EditingCanvas1-PowerApps.png

 

MY POWERAPP EDITING CANVAS SCREENSHOT 2

Another try with a different value for the Item property for Form1 (Screen2).  This value was copied from the FormScreen1 which PowerApps created for me.   But again, do not let the Item property get in the way.  It may not be the cause of my problems. 

 

EditingCanvas2-PowerApps.png

 

IMPORTANT NOTE:  No matter how I customize my form using Power Apps or how I create a Power App that uses SharePoint as my underlying data source, I cannot get around this issue.  Maybe I am just missing something.  Could be.  The same issue happens if I go to List Settings and in Form Settings I choose the option to Use a custom form created in PowerApps (requires new list experience).   I also have the issue when I start from the Power Apps service and not the SharePoint list...details below. 

 

See below for details and screenshots on my experience when I start from the Power App Service:

 

  1. Opened PowerApps service
  2. Chose to create an app from SharePoint

 

StartwithSharePoint.png

 

 

PowerApps created the standard 3 screens for me, which I do not want. See below.

 

CreatedForMe.png

 

My app is primarily a form, so I do not want a Browse screen or a Details (display item) screen.  I want 4 edit screens with approximately 5 fields (SharePoint columns) on each with a Next icon at the bottom of the screen to allow the user to navigate between screens. My design approach is to use simple screens with fewer fields.  I deleted screens 2 and 3 and totally wiped out everything on screen 1 and added my own Edit Form.

 

When I added my own Edit Form I had to connect it to data, so I chose my SharePoint environment, then my list and PowerApps created the data connection and set my new Edit Form Data Source to my list name and my Item Property to blank (this should work per this guys comments mid-way down in his post).  See below.  

 

DataSourceandItemPropertyValues.pngItemPropValue.png

 

Note:  PowerApps configured the above properties for me when I added my Edit form and then connected it to my SharePoint list - I would expect them to work and not for me to have to correct them or reset them. 

 

  • I then then duplicated Screen 1 (this function is available by hovering next to Screen 1, then clicking the three arrows that appear and then the Duplicate Menu option) and got a new screen which I renamed to Screen2.  Since it was duplicated, it had the same components (Edit Form with DataSource set properly and Item property set to blank).
  • I added a Next icon at the bottom of Screen 1 using a custom data card and rigged it up to move the user to Screen2.
  • Then I saved my app, published my app, gave permissions to everyone in my org to use the app.
  • Then I navigated to the app and to my disappointment, I still got the "Getting your data" message which actually never gets my data.  See below.

 

GettingYourData2.png

 

 

Am I missing something?  Is this a bug?  If a bug, this is a big one.  As I mentioned early on in this post...it seems others are having similar issues.  This shouldn't be this hard.  I would love to hear from others on this and I am pursuing this with Microsoft.  Hoping to get answers soon. 

 

Kind regards,

 

Bill 

2 REPLIES 2
Community Support Team
Community Support Team

Re: Stuck getting data with SharePoint List as Data Source

Hi @WillyD44,

I have made a test on my side, and don't have the issue that you mentioned. The screenshot as below:1.JPG

 

2.JPG

Note: The FormScreen1_1 is a duplicated screen of the FormScreen1.

The GIF screenshot as below:Test1.gif

 

Please make sure that the Edit form (on your side, it is Form1) within your Screen2 is connected to same data source with the SharePointForm1 within your first screen (FormScreen1).

In addition, please modify your formula within the OnNew property, OnEdit property, OnView proeprty, OnSave property and OnCancel property of the SharePointIntegration control as below:

Set the OnNew property of the SharePointIntegration control to following:

 

NewForm(SharePointForm1);NewForm(Form1)

Set the OnEdit property of the SharePointIntegration control to following:

 

EditForm(SharePointForm1);EditForm(Form1)

Set the OnView property of the SharePointIntegration control to following:

ViewForm(SharePointForm1);ViewForm(Form1)

Set the OnSave property of the SharePointIntegration control to following:

SubmitForm(SharePointForm1);SubmitForm(Form1)

Set the OnCancel property of the SharePointIntegration control to following:

ResetForm(SharePointForm1);ResetForm(Form1)

then check if the issue is solved.

In addition, please check and see if the following blog would help in your scenario:

https://powerapps.microsoft.com/en-us/blog/separate-custom-forms/

 

If the issue still exists, please consider take a try to remove the custom form from your SP list, then re-create a new custom form, then try a try with the above solution I provided, check if the issue is solved.

More details about deleting a custom form, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/customize-list-form#delete-the-custom-f...

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
WillyD44
Level 8

Re: Stuck getting data with SharePoint List as Data Source

Thanks Kris.  I was counseled by another before you posted your response to change the Form Default mode property to "New".  I found this property when I have the form selected, in the right side bar in the Properties selection.  Does that make sense?  Do you understand what I'm referring to?  This worked.  But I'm curious what the difference is between what I did (changed the Default mode of the form from Edit to New) and what you suggested regarding changing the OnNew, OnEdit, etc. properties within SharePointIntegration?

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,447)