cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mr-dang
Level 10

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

@tommyly, I'm thinking you need to clear the globalVarID variable when you're done on the screen. This cleans things up.

 

Set(globalVarID,Blank())

 

Also, instead of using a condition to tell the form whether to be in edit or new mode, you can just do it straight from the edit and add buttons on the previous screen. It saves you guess work and conditions.

 

Set(globalVarID,ThisItem.customID);
EditForm(form1)
Microsoft Employee
@8bitclassroom
tommyly
Level 8

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

@mrdang

That seems to be more consistent: using EditForm or NewForm from the previous screen. Thanks!

I'm guessing the problem I had may have had to do with a discrepancy in the order in which events trigger versus when forms update. My initial instinct is that everything happens chronologically, but there may be some unexpected timing that cased the form to update out-of-step when altering it (e.g. EditForm/NewForm) in an OnVisible event. 

Anyway, I will start using EditForm and NewForm from the invoking screen rather then rely on an if-statement within an OnVisible event.

GK_BPL
Level: Powered On

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

You said that syntax was the problem, can you please write the code for me, cause I'm havin the same problem!!

Thnak you very much

PowerApps Staff AllenKim
PowerApps Staff

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

Hi @GK_BPL,

 

The syntax solution metioned earlier is probably specific to the other user's app/rules. It would be best if you create a new topic and post details specific to your issue so we can help. If there is a specific action that doesn't work in Play mode, then providing the rules for that action would be a good start.

 

Thanks,

Allen

Anonymous
Not applicable

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

@AllenKim, I am having a similar issue the past couple days, which I have posted about here: https://powerusers.microsoft.com/t5/General-Discussion/Bug-date-field-not-getting-saved-in-play-mode...

 

When I turn off the "Delayed Load" setting, it seems to be fixed.  Could this be a bug?

 

 

PowerApps Staff AllenKim
PowerApps Staff

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

Hi @Anonymous,

 

I replied to your original post. Let's use that post to track your issue.

 

Thanks,

Allen

GK_BPL
Level: Powered On

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

Hello, The App is working perfectly again after i switched off some new updates from Microsoft

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,499)