cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JamesM
Level 8

Trying to populate ListBox from a Collection of records not working-displays 1 item containing text

If I manually add the following to the items value of my ListBox 

 

["value","value2","value3"]

 

I get

 

value

value2

value3

 

But if you look at the screenshot below, I am getting back the string ["value","value2","value3"] from Microsoft Flow, adding that to a Collection and trying to use that with my LisTBox, but it creates a single item with the text of the string. 

 

2018-12-07 09_47_15-Window.png

I'm guessing I need to do some kind of split operation? but i'm not sure how - anyone?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
JamesM
Level 8

Re: Trying to populate ListBox from a Collection of records not working-displays 1 item containing t

Never mind, found it - just needed to Split within the Items property, e.g. 

 

Split(Text(First(customGroups).Value),",")

View solution in original post

1 REPLY 1
Highlighted
JamesM
Level 8

Re: Trying to populate ListBox from a Collection of records not working-displays 1 item containing t

Never mind, found it - just needed to Split within the Items property, e.g. 

 

Split(Text(First(customGroups).Value),",")

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,232)