cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
simms7400
Level 8

Why isn't Coalesce working?

Hi Folks -

 

I have an field (Asset ID) I do not display to the end user at any time as it's just a unique I populate with an MS Access VBA routine after submission. However, I upon intial submission, I populate it with whatever is available in the Alias field (Asset Alias).  Recently, I found out this wasn't working...

 

I would expect the value of Asset Alias to be in Asset ID:

asset.jpg

 

Here is my Defauly propety of Asset ID:

Coalesce(ThisItem.Name,ThisItem.Alias)

 

Keep in mind,  Name = Asset ID and Alias = Asset Alias.

 

Would anyone know why this isn't working? I even tried to reference another field and it still doesn't work.


Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Why isn't Coalesce working?

Hi @simms7400 ,

Based on the issue that you mentioned, I think there is somethin wrong with your formula.

 

Before you submit a new record (intial submission), the ThisItem.Name and ThisItem.Alias formula in your Edit form (in New mode) would both return blank. So the Coalesce() function within your app would return blank.

 

I have made a test on my side, please take a try with the following workaround:

Set the Default propety of Asset ID to following:

Coalesce(ThisItem.Name, EditForm1.Updates.Alias)

or

Coalesce(ThisItem.Name, AssetAliasTextBox.Text)

Note: The EditForm1 represents the Edit form in your app. The AssetAliasTextBox represents the Text Input box within the Asset Alias data card.

 

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Community Support Team
Community Support Team

Re: Why isn't Coalesce working?

Hi @simms7400 ,

Based on the issue that you mentioned, I think there is somethin wrong with your formula.

 

Before you submit a new record (intial submission), the ThisItem.Name and ThisItem.Alias formula in your Edit form (in New mode) would both return blank. So the Coalesce() function within your app would return blank.

 

I have made a test on my side, please take a try with the following workaround:

Set the Default propety of Asset ID to following:

Coalesce(ThisItem.Name, EditForm1.Updates.Alias)

or

Coalesce(ThisItem.Name, AssetAliasTextBox.Text)

Note: The EditForm1 represents the Edit form in your app. The AssetAliasTextBox represents the Text Input box within the Asset Alias data card.

 

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

simms7400
Level 8

Re: Why isn't Coalesce working?

Hi - Worked like a charm - thank you!!

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 172 members 5,985 guests
Please welcome our newest community members: