cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Microsoft Employee

powerapps view not showing in Sharepoint list

Hello,

 

When powerapps is created from SharePoint list we are able to see the view in the list. When the powerapp is created (from powerapps portal) and associated with a SharePoint list it is not showing the view in Sharepoint list. Is this the expected behavior?

 

Thanks,

Madhan

10 REPLIES 10
Community Support Team
Community Support Team

Re: powerapps view not showing in Sharepoint list

Hi Madhan,

 

Did you mean that when you on the PowerApps studio and let powerapps create the app using the SP connection, you can see the views in list? If so, would you please take a screenshot of this situation?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Re: powerapps view not showing in Sharepoint list

Hi Madhan,

 

If I understand your question correctly, then I believe it is behaving as expected, yes.

 

This does however depend on what you're doing and how you're doing it.

 

When you create a new app, either from the SharePoint PowerApps link on a list, or from the PowerApps portal, you set up the connection context for that app as it is created.  On creation, PowerApps can make a fair assumption that you want a quick and easy app based on the data source you create from.  The app then builds the relevant screens and grids and populates them with the data from the list.

 

If you create an app and then add a data source to it, it does not build the screens and populate the data.  I would imagine this is by design, as you can add any number of data sources to an app, and it would be quite painful if PowerApps built view/edit/update screens with default layouts every time you added a data source.

 

So, in short, I'd say - when creating an app, either by launching "Create App" from the PowerApps dropdown menu on a SharePoint list, or choosing the SharePoint List template to create an app in the portal - it will automatically create those views and populate them.

 

When you're adding a data source to an existing app, it will not.

 

Hope this helps!

 

R

Microsoft Employee

Re: powerapps view not showing in Sharepoint list

Hi Russel,

 

I created two powerapps.

 

1. Created from SharePoint list. (Powerapps -> create an app)

 

I am able to see the view.

 

2. From the powerapps portal, new app -> SharePoint (start with your data) and associated the same list mentioned in point 1.

 

I am not able to see the view.

 

As per your below explanation, the highlighted point in red is not happening.

 

So, in short, I'd say - when creating an app, either by launching "Create App" from the PowerApps dropdown menu on a SharePoint list, or choosing the SharePoint List template to create an app in the portal - it will automatically create those views and populate them.

Microsoft Employee

Re: powerapps view not showing in Sharepoint list

1.png2.png3.png

Anonymous
Not applicable

Re: powerapps view not showing in Sharepoint list

.

 

Anonymous
Not applicable

Re: powerapps view not showing in Sharepoint list

Hi Madhan,

 

Difficult to say what the problem could be based on the info you've provided.  It works fine from my side so there's either something wrong with the process you're following or there's a context we're missing somewhere.

It would be easier to see, step for step, screen for screen and click for click, what you're doing.

 

Can you take a screen recording and link it?  

You can use powerpoint and office mix (it's free) and post it to mix.office.com

Otherwise a screenshot per click, which might be tedious

 

Some questions:

  • Is it building the sceens but the cards are just blank, or is it not even building the screens?
  • Once it's finished building, does the list appear under data sources for the app?
  • If you click on a field on a card, can you select a field from a dropdown on the right, and are these fields your list columns?

 

Some things to check;

  • Try using the powerapps studio desktop client, see if that makes a difference
  • Check the browser window that gets launched from SharePoint is the same browser you're using from the portal (sometime people use two browsers and the experience might be different)
  • Check and see if the environment the app gets creates in from SharePoint is the same as the one from the portal.  Also confirm that all your PowerApps connections are authenticated and active and double check that the list and the user you're using to access it are identical in both cases

Beyond that, bit difficult to say, need more detail...

 

Good Luck

 

R

Microsoft Employee

Re: powerapps view not showing in Sharepoint list

Hi Russel,

 

All the functionalities are working except the view is not getting displayed. i have uploaded the repro steps in office mix.

 

https://mix.office.com/watch/5at5205cvmz8

 

Thanks,

Madhan

Anonymous
Not applicable

Re: powerapps view not showing in Sharepoint list

Hi Madhan,

 

Thanks for the mix - now it makes perfect sense.  Where I thought you were talking about data in the app, I see now you were talking about the SharePoint list views 🙂

 

I would say, yes, it's behaving as expected - although if you rely on the list view it might perhaps be worth mentioning on the Ideas forum for them to include an option from the portal and Studio side.  Personally, I've never used it 🙂

 

By way of explanation;

 

  • When you initiate an App from SharePoint it's a SharePoint action - The PowerApps menu on the list is SharePoint code on the SharePoint site.  When you select it, SharePoint initiates the app creation process and tells PowerApps what the source is (the list you pushed the PowerApps button on).  
  • Because SharePoint initiates it, it is fully aware that you are busy creating an app in the context of your list and it can therefore create the view on the list for you as part of the 'app creation process' from SharePoint.  This part is 100% SharePoint and PowerApps isn't aware of the view at all.

 

  • When you create an app from the portal or the PowerApps Studio, although you specify the SharePoint list as the source, nothing 'tells' SharePoint you're busy creating an App.  The data source connection is just a connection - SharePoint has no clue you're creating an app from that side and so, no view is created 🙂

As I said, if you think it should be on both sides, perhaps post it to the ideas/feedback forum.  To be honest, I never noticed it before Smiley LOL

 

 

R

Microsoft Employee

Re: powerapps view not showing in Sharepoint list

Hi Russel,

 

Thanks for looking into it. i will post the same in "submit ideas".

 

Thanks,

Madhan

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (6,566)