cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WatermelonCat
Level: Powered On

Re: A weird bug for my tracker

Table1_7 is a new table I made with the ToggleValue column. I have a video of my problem. 

https://drive.google.com/open?id=1p4dz2C07rj8oCeB1Tx6cbNRf3NYLESwU

Community Support Team
Community Support Team

Re: A weird bug for my tracker

Hi @WatermelonCat ,

Please consider take a try with the following workaround:

1. Remove the formulas within the OnCheck property and OnUncheck property of the Toggle control.

2. Then set the OnChange property of the Toggle control within the Gallery to following:

If(
   Toggle1.Value = true,
   Patch(Table1_6, ThisItem, {ToggleValue: "Yes"}),
   Patch(Table1_6, ThisItem, {ToggleValue: "No"})
)

3. set the Default property of the Toggle control to following:

If(ThisItem.Toggle = "Yes", true, false)

4. Set the TemplateFill property of the Gallery to following:

If(
   ThisItem.ToggleValue = "Yes",
   LightBlue,
   RGBA(0,0,0,0)
)

Please consider take a try with above formula, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
WatermelonCat
Level: Powered On

Re: A weird bug for my tracker

It works but once I turn the toggle on it changes back to off. https://drive.google.com/open?id=1a1uNrHDeJepqNwGaa-fttQBA5_UdRiqG

Eelman
Level 10

Re: A weird bug for my tracker

@WatermelonCat change the Default property of the Toggle to If( ThisItem.ColorFill = 1, true, false). This assumes that you've created 2 collections as per my previous post?

 

I've got it working using this approach ie colour changes and toggle, well, toggles between On/Off and stays on selected value.

Community Support Team
Community Support Team

Re: A weird bug for my tracker

Hi @WatermelonCat ,

I have made a test on my side, and don't have the issue that you mentioned. Please check if the ToggleValue column has been populated with proper values when you check the Toggle control in your app.

 

If the issue still exists, please consider re-create a new app based on your data source, then try above solution again, check if the issue is fixed.

 

Please make sure you do not add any other formulas within the OnCheck proeprty and OnUncheck property of the Toggle control.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Platform 24

Check it out!

thirdimage

New Badges

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

Top Solution Authors
Top Kudoed Authors
Users online (5,593)