cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JamesM
Helper V
Helper V

Access Token has missing scopes for the Audience error occuring across all Flows/Custom Connector calls in App - affecting all users

Hi all, 

 

My app was working fine yesterday for all users, and there have been no changes, but today it is failing for all users on all devices, with the following error occuring multiple times, for any Flow connection or Custom connector call within the App. Any ideas? 😞 

Untitled.png

 

9 REPLIES 9
t19670
Advocate II
Advocate II

Same here!
ericonline
Community Champion
Community Champion

Hi @JamesM,

There are many people experience issues right now. For your case in particular (being in Australia), support.powerapps.com shows a known issue.

It will likely be resolved soon.

 

@t19670, are you in Australia too?

No In UK
ericonline
Community Champion
Community Champion

Wow ok. Does your error message show "Office365Users" as the culprit or is another Connector listed?

Same issue, NYC, USA . 

 

file-3.jpeg

The error is:
The requested operation is invalid.
Server response: Error from token exchange: Bad authorisation token. The access token has missing scopes for Audience https://apihub.azure.com AllowedScope [user_impersonation] TokenScope:Runtime.All
ericonline
Community Champion
Community Champion

Looks like there is potentiall two things going on. One involving "Australia" as a whole hence @JamesM's OP and another involving "everyone" who uses the Office365Users connector.

I say this because support.powerapps.com lists a known issue in Australia and @JamesM is the only one i've seen so far who has a Flow issue. All others (that I've seen) are related to the O365 connector.

Our license here is the O365 license / plan, not sure if that has bearing. My App uses only the following types of external calls: 

 

- Calls to MS Flow (to invoke Azure Table Storage, HTTP requests etc)

- Calls to a HTTPS Custom Connector (which backs onto AWS API Gateway) 

 

Both are in a non-working state at the time of writing. 

ericonline
Community Champion
Community Champion

You know what... that makes me think of something...

There is a big licensing change happening right now  ("2/2019") that will require a PowerApps Plan 1 license for all users of apps with Custom Connectors and HTTP Calls in Flow. (there are all kinds of caveats so read the post thoroughly)

Wonder if the back end changes are causing this issue.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (86,401)