cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

AddColum() doesn't work

Hello,

 

I'm trying to create a browse gallery from 2 different sharepoint lists with different columns. To do this I'm trying to make a data table for each sharepoint list and join them. The problem is when I try to add a column to the data table (so you can see what system it pertains to) it doesn't update. 

I'm using the following on a button. 

 

AddColumns(eBR_Requests,"System Request",Text("System X"))

 

 It doesn't give me any errors but the result to the collection after use is: 

pa_collection.png

 

 

 

 

 

As you can see, no column named "System Request" with the value "System X" appeared. 

 

 

 

 

If there's another way to add a hardcoded column into a collection that's easier I'm happy to hear it. 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User II
Super User II

Re: AddColum() doesn't work

Combine your AddColumns table shaping function when you perform the Collection. I can't tell if that's your collection's name or the source, but use the syntax below with your values and it should work. By doing it as part of the Collect function, you are adding the column explicitly to the collection itself.

Collect( collectionName, AddColumns ( datasourceName , newColumnName, newColumnValue ) )

Doing it afterwards is a 'virtual' way of adding a column, if you were adding it for any control which references a table.

View solution in original post

3 REPLIES 3
Highlighted
Super User II
Super User II

Re: AddColum() doesn't work

Combine your AddColumns table shaping function when you perform the Collection. I can't tell if that's your collection's name or the source, but use the syntax below with your values and it should work. By doing it as part of the Collect function, you are adding the column explicitly to the collection itself.

Collect( collectionName, AddColumns ( datasourceName , newColumnName, newColumnValue ) )

Doing it afterwards is a 'virtual' way of adding a column, if you were adding it for any control which references a table.

View solution in original post

Highlighted
Frequent Visitor

Re: AddColum() doesn't work

@GarethPrisk that did add the text to the column. However unfortunately it made my problem much, much worse. I'm gonig to create a new topic about trying to merge two sharepoint lists into one browse gallery. 

 

 

Highlighted
Super User II
Super User II

Re: AddColum() doesn't work

Sounds good. Feel free to tag me on that post, and I'll lend a hand!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Find your favorite faces from the community presenting at the Power Platform Community Conference!

Watch Now

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (7,730)