cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
emfuentes27
Advocate III
Advocate III

Almost every single formula shows error

I was working on an apps a couple of days ago, and when I opened the apps this morning again, almost ever single formula was showing errors. Something as simple as Parent.Height says 'Invalid use of "."':

 

Annotation 2021-08-25 085954.jpg

 

What could be happening? I also noticed that when you type something, most of the suggestions don't make sense if shown at all. For example, when I type "Parent", the only suggestion is shows is "Transparent". Then, if I change the Parent.Height to a number, I get a different error that doesn't make any sense, as that hamburger_icon's width is also just a number:

 

Annotation 2021-08-25 085954.jpg

 

Is PowerApps going crazy or something?

5 REPLIES 5
RandyHayes
Super User
Super User

@emfuentes27 

Is this in a component?  I notice you tagged the post as Components.

If so, components DO suffer from strange behavior in the designer.  If come across this several times and getting out and back in sometimes resolves it.

 

Also, your Height property is complaining about a circular reference to the Width property...what is going on in the Width property?

 

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!
Ruqhaiya01
Regular Visitor

Hi, 

I think this is because of the current authoring version you're using. 

 

Try rolling back to a previous version. 

 

You can do this by going to:

 

Canvas app -> File -> Settings -> Support -> Edit (you will find this just below authoring version)  

 

In the dropdown you will see different versions and you'll see the recommended version too. 

 

VersionAnswer.PNG

 

Hope this helps!

 

 

 

emfuentes27
Advocate III
Advocate III

Thanks @Ruqhaiya01.Actually, rolling back to an earlier version was one the first I did when this errors started too show up. Even those earlier versions that worked perfectly now show the same error all over the place. I also had saved some versions locally in my computer, and still the same errors. There is something funny happening with PowerApps.

Thanks @RandyHayes. Yes, this is a component that I created to use it as a navigation menu. As I mentioned, it was working just fine the last day I worked on it. I also rolled back to earlier versions, and used a few versions I saved locally in my computer, and now they all show the same errors.  That message about circular reference doesn't make sense, as that Width property is just a number, 40 to be exact. Something very strange is happening to PowerApps today, and I just can't figure it out.

RandyHayes
Super User
Super User

@emfuentes27 

Yes, they seem to be really working a lot on the components in PowerApps lately as there has been a lot of problems with them over the past couple weeks.  Especially with libraries!

The only thing that I can suggest is a fresh app and "Rebuild" the component in that app.  Just the component and nothing else needed in the app.  This is a fruitless exercise in regard to your real app, but more of an exploratory exercise to see if the problem happens in a fresh app.  If so, then a support ticket to Microsoft would be on the agenda, if not, then perhaps it will yield some clues as to what you might be able to adjust in your real app to resolve the issue.

 

Also, in your real app, consider making a duplicate of the component you have and see if the errors follow over to the duplicate.

 

Personally, I love components, but there are some days that they are more work than they are worth - and all of that extra "work" is ONLY because there is something screwed up in the designer...not because of the component itself.  And, I find myself doing a lot of the above juggle, shuffle and scream methods to try and make them work only to get to a point where it works and you look it over and say "that's EXACTLY what I had before!!".

There are currently two features that are considered experimental about components, but I treat the whole component concept as experimental.  

 

I am only just starting my day of PowerApps work, so I've not been in the designer yet to see if I experience similar issues - as I use components pretty much everywhere.  So, we'll see what happens here shortly.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (3,686)