cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dsc
Regular Visitor

Android phone: Camera control gives black pictures

I created an app with camera functionality. While the app is working on my computer in my Android phone the camera control is not working right:

At first the app hangs showing a kind of playbutton where the camera control field is. Then the camera seems to be initialized but stays black. The control will take pictures but only black pictures.

 

As suggested in another thread I changed the Camera-property of the Camera control to different values. I also added a slider to control the Camera-property with values between -1 and 2. For values 0 and 1 I get what is described above. For -1 and 2 would give an error of a camera that is not correcly initialized or used.

 

Any idea how to fix this?

 

Thanks in advance.

5 REPLIES 5
v-yamao-msft
Community Support
Community Support

Hi dsc,

 

The first time you open the app on the Android phone, have you allowed the app to access Camera?


What’s the Android version of your device? And what’s the PowerApps version on your side?

 

To test this issue, I create a simple app with a Camera control and an Image control. I do nothing on the Camera control, for the Image control, set its Image property as Camera1.Photo.


Then open the app on my Android phone(version 7.0), allow access to Camera. I found that it is working fine, when I click the Camera control, it will take a photo and the photo will be shown on the image control.

 

Please try to create a simple app and run it on your Android phone to see if you will still get the same issue.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Yes I did allow access to the camera.

I build a simple test app as you described. The issue stays.

Initialization of the app (camera) takes long.

I get a blank camera control. when I click I get a black photo.

 

My andorid version is 7.1.1.

dsc
Regular Visitor

Any thoughts on this?

Anonymous
Not applicable

Hi,

 

Exactly the same problem here. My camera app is working on a Nexus 5 on Android 6.0.1 but I have the same symptom as DSC on a Huawei with Android 7.0.

 

Any idea?

Thanks,

Anonymous
Not applicable

I have the same issues with Huawei  and Android 7.0 - the Camera is either a black square with a grey play symbol on top or a black screen.

I have granted PowerApps the rights to use the camera.

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Power Apps Community Call Jan. 2022 768x460.png

Power Apps Community Call

Please join us on Wednesday, January 19th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,378)