cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tom_garvin
Advocate III
Advocate III

App insists on asking for permission to use location - how to suppress, client objects on privacy

I started developing an app which incidentally collected location information into the database. The clients employees objected when they were asked to allow location services when installing the app.

 

The client asked me to remove that capability, which I attempted to do. Yet the app continues to ask for permission.

 

I've searched every known and every potential location in my app for any functions which reference the "location" function.

 

I cannot find any. It is possible the "search" function does not look everywhere. Any ideas on how to dig deeper?

 

Alternatively, is there some other aspect of the app which might set off the "need GPS info", other than the usual, lat, long, altitude and heading?

2 ACCEPTED SOLUTIONS

Accepted Solutions

The "official answer" is that when you use the Location function the app will ask the user for permission. Not a problem.

 

In my case, the client insisted on geo information collection in the original design. Due to employee resistance they then changed their mind and asked to remove that function. The geo information was recorded in the database along with date/time of the input submissions, but the users were concerned with the appearance of active tracking of their movements.

 

As the sole developer, I removed all instances of the function, refreshed the data sources (Azure SQL Database) and eventually removed those fields from the database. But the prompts remained.

 

I used PowerApps search capabilities to hunt down ever potential instance of an orphaned "location", but the search missed ONE instance, on a "retired" test screen used as an R&D sandbox. Work done three months ago, completely forgotten.

 

So, finally, I made a copy of the app and started deleting likely suspects, closing and re-opening, finally I removed the "infection". 

 

The only real issue now is why I could not find that remaining function call, incidentally in an add/edit card. It could be a deficiency in PowerApps search or heaven forbid, I don't know what the heck I'm doing. It can happen <g>

View solution in original post

Thanks to Umair Iqbal from MS Support, we were able to track down the problem.
It was indeed a rogue "Location" statement in an OnVisible property of a HtmlText control.
It is frustrating that Power Apps doesn't provide some global search facility, so I had to delete one screen at a time, publishing and playing it on each occasion, until the issue disappeared. I then restored the app and deleted one control at a time i the sam e way
This seems to be the only solution
Cheers Umair!

View solution in original post

6 REPLIES 6
v-xida-msft
Community Support
Community Support

Hi @tom_garvin,

 

Could you please share a bit more about the issue on your side? Could you please share a screenshot about it?

Do you mean that the end users are asked to allow location services when installing the app?

 

Please check if you have used the Location function within the app that you created.

 

I have made a test on my side, if I use Location function within my app, when I run the app within my Android device, I would be asked to allow location service:2.jpg

If you use the Location function within your app, and want the end users to get rid of being asked to allow location service, I afraid that there is no way to achieve your needs in PowerApps currently.

 

If you would like this feature to be added in PowerApps, please submit an idea to PowerApps Ideas Forum:

https://powerusers.microsoft.com/t5/PowerApps-Ideas/idb-p/PowerAppsIdeas

 

More details about the Location function in PowerApps, please check the following article:

Location function

 

Best regards,

Kris

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

A clarification: we did use the Location function. Got pushback.

 

Deleted every known occurrence of the Location function.

 

Republished, 

 

Users are still being requested to authorize location services.

 

I used the Search capability to look for most likely only one stray occurrence of the Location function call.

 

Perhaps Search does not search everywhere, but as the developer, I've looked in every likely spot, no luck.

 

Sometimes I miss Visual Studio, you can find anything. Of course you need a robust search capability when working with a million lines of C#

The "official answer" is that when you use the Location function the app will ask the user for permission. Not a problem.

 

In my case, the client insisted on geo information collection in the original design. Due to employee resistance they then changed their mind and asked to remove that function. The geo information was recorded in the database along with date/time of the input submissions, but the users were concerned with the appearance of active tracking of their movements.

 

As the sole developer, I removed all instances of the function, refreshed the data sources (Azure SQL Database) and eventually removed those fields from the database. But the prompts remained.

 

I used PowerApps search capabilities to hunt down ever potential instance of an orphaned "location", but the search missed ONE instance, on a "retired" test screen used as an R&D sandbox. Work done three months ago, completely forgotten.

 

So, finally, I made a copy of the app and started deleting likely suspects, closing and re-opening, finally I removed the "infection". 

 

The only real issue now is why I could not find that remaining function call, incidentally in an add/edit card. It could be a deficiency in PowerApps search or heaven forbid, I don't know what the heck I'm doing. It can happen <g>

View solution in original post

Hi
I'm also having this reported by users. 
Is the problem a rogue "Location" call somewhere in the App attributes?
What's the strategy to find this, outside of looking at every control setting?
Thanks
Bill

Thanks to Umair Iqbal from MS Support, we were able to track down the problem.
It was indeed a rogue "Location" statement in an OnVisible property of a HtmlText control.
It is frustrating that Power Apps doesn't provide some global search facility, so I had to delete one screen at a time, publishing and playing it on each occasion, until the issue disappeared. I then restored the app and deleted one control at a time i the sam e way
This seems to be the only solution
Cheers Umair!

View solution in original post

“If you try and take a cat apart to see how it works, the first thing you have on your hands is a non-working cat.” ― Douglas Adams

 

Moral: only use this technique if you have another cat to spare

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Top Kudoed Authors
Users online (45,783)