cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jdscott
Helper II
Helper II

App not communicating with Excel table

I copied and pasted two columns into my database table and my app will no longer read data from that table. My database is an excel sheet stored in dropbox and has not had problems until now. 

 

I've tried deleting formatting from the table, disconnecting the table and reconnecting, deleting the new columns. I've changed the datasource for the gallery to an adjacent table in the same excel sheet and it communicates swimmingly. 

 

Any ideas what I did to my table that PowerApps will recognize it, but not read any of its data?

1 ACCEPTED SOLUTION

Accepted Solutions
timl
Super User
Super User

Hi @Jdscott

 

For these types of error, I would suggest that you copy all your data into a new Excel file, and to replace your existing spreadsheet with the new file.

 

I also recommend placing each table in separate worksheet. PowerApps needs to create an auto-generated __PowerAppsID__ column for each table. Placing each table in a separate worksheet prevents any problems that might occur if there isn't space between the adjoining tables in a worksheet.

 

View solution in original post

4 REPLIES 4
timl
Super User
Super User

Hi @Jdscott

 

For these types of error, I would suggest that you copy all your data into a new Excel file, and to replace your existing spreadsheet with the new file.

 

I also recommend placing each table in separate worksheet. PowerApps needs to create an auto-generated __PowerAppsID__ column for each table. Placing each table in a separate worksheet prevents any problems that might occur if there isn't space between the adjoining tables in a worksheet.

 

View solution in original post

After redoing many of the data and item fields in my app, I finally had the app working again. Then PowerApps stopped communicating with my new table.

 

What gives? 

 

Help me out, Microsoft. What am I doing to break your program?

Jabberco
Frequent Visitor

I am having the same problems. Experimenting with PowerApps and the datasource being an Excel file in OneDrive for Business. Cannot get it to work in a stable fashion. Data disappears often, ie. the App is not always updating the Excel file when adding a new record. The format of the date column regularly gets messed up. 

However: using SQL Server on a local machine as the data source works well.

J.

JT84
Helper I
Helper I

Despite having my tables on separate spreadsheets I am experiencing problems working with OneDrive for Business Excel. Redoing all my tables in a new workbook is not a solution and should not be accepted as such.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,005)