cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

App sometimes won't load

I've seen sometimes users have problem to open an app, when they use directly app link from bookmarks (not from a portal).
They don't get further than initial loading screen (the one with spinner).
Users can be waiting for few minutes, but nothing is being loaded. They try to open it again after a while, but still same problem. Usually it starts to work after 5th-6th attempt.

 

I've made pretty simple app for submitting requests having only 4 screens, 3 different forms, 1 connection (to SharePoint Online). Application is loading no data, this app is purely only for submitting, so there should be nothing that can cause a problem.
The only 2 commands I used in App "OnStart" are settings variables like:

 

Set(var_username,User().FullName); 
Set(var_maincolor,RGBA(102, 0, 102, 1)); 

 

but even with simple app like that users have same problem.

I was not able to replicate the problem with my account on any of our apps.


Any idea what can be wrong or how to investigate the problem? Sometimes it works just fine, but sometimes it just get stuck and it's not isolated only to one app, but more  generic problem.

3 REPLIES 3
Highlighted
Super User
Super User

Re: App sometimes won't load

Hi @marekbuban,

Have you considered comparing the parameters of the working apps with the ones from the not working apps? Maybe one experimental feature is causing the problem.

Also, try commenting the User() function in your application just to make sure that it's not the access to the AD that is causing the problem...

Tell us how this goes...

Emmanuel

Highlighted
Helper II
Helper II

Re: App sometimes won't load

Thanks @R3dKap  for your answer.

I use no experimental feature in these apps.

I've tried to comment the User() function and will wait for it to be tested by users, but I doubt it will help, as other apps with same problem doesn't use that function.

Highlighted
Microsoft
Microsoft

Re: App sometimes won't load

Can you please provide the session ID next time this happens?  Please obtain the session ID, please follow the instruction below.

 

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/get-sessionid

 

If you are not able to see the setting icon because you are stuck on the splash screen, please hit F12 key to open the developer tool of the browser.  Go to the Console window and type Core.Telemetry.Log.sessionId; and hit enter.  You should see the session ID displayed.  Thanks.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors
Users online (5,428)