cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Melissaed26
Helper I
Helper I

App stopped working

I have an app used for defect data entry. The user enters defects, and can modify an entry they have already entered. The user finds the entry in a gallery selects it, and from detail screen can choose to modify it. This app has been working since January. Yesterday some of the controls stopped loading when user is trying to modify. I have checked everything that I can think of. If I create a new record, I can then choose that item and others from the gallery to modify and all data will load. If I completely close out of the app it will stop working correctly again.

 

Please help

6 REPLIES 6
Drrickryp
Super User
Super User

Hi @Melissaed26 

Try deleting the datasource from your app and then reconnecting to it.  When you delete it all of your controls will error out but don't worry, when you reconnect, they should all be working again.    I have found that this often corrects the kind of problem you have described.

Thank you I tried this and I am still having the issue. It works on my computer but not on the mobile version. Most of my users interact with the mobile version. It is the drop down controls that are not populating the data.

What are you using for the datasource in the items property of the dropdowns that won't work?

It is connected to a sharepoint list. It works when they are adding new data. Issue happens when they select a record and trying to add detail. The drop down items should bring in the previously selected items. This was working for past few months and has stopped Working. 

@Melissaed26 

It sounds like there is a problem with the Default property of the dropdown (combobox?).  Using the fields list on the edit form, remove the ones that aren't working and then reselect them again. 

@Drrickryp 

 

I have checked the defaults and they are correct. As they were working up until a few days ago. And when I do it on my computer it works. When go to my cell phone to be sure still it is working it It will not populate those fields. Is there a way I can collect the data once the item is selected in the gallery? This way I will show? 

 

detail screen.pngeditform .png  The first pic is the detail screen. The second pic is the edit screen. The Value stream, Model, and Part Type are drop downs when the edit screen is in new mode. I have them as view when in the edit mode as these won't change. Can I collect this data when the user selects it from the gallery? May help with performance issues as well. The sharepoint list is getting large as more data is collected.gallerygallery

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,237)