cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
simkessy
Helper I
Helper I

App will not close after Patch

I'm trying to get the application to close after patching but it just stays open: 

If(SPForm.Mode = FormMode.New,
    Patch(
        ParentList,
        Defaults(ParentList),
        {
            Title: formTitle.Text, 
            child: ForAll(ChildSelector.SelectedItems,{       '@odata.type':"#Microsoft.Azure.Connectors.SharePoint.SPListExpandedReference",
                Id: ID, 
                Value: Title 
                })
        }
    ); ResetForm(SPForm);RequestHide(),
    Patch(
        ParentList, 
        SharePointIntegration.Selected, 
        {
            Title: formTitle.Text, 
            child: ForAll(ChildSelector.SelectedItems,{       '@odata.type':"#Microsoft.Azure.Connectors.SharePoint.SPListExpandedReference",
                Id: ID, 
                Value: Title 
                })
        }
    ); ResetForm(SPForm);RequestHide();
);
ResetForm(SPForm);RequestHide()

 

26 REPLIES 26
Anonymous
Not applicable

Same, our custom form now closes correctly after submitting.  Thanks @chmoncayMSFT and the team for such a quick turnaround in getting this fixed up!

Mine is now working as well. Thank you.

v-xida-msft
Community Support
Community Support

Hi @simkessy ,

Just an update -- Currently, the issue has been fixed within Custom form in SP List.

 

Please consider clear cache of your browser, then try your custom form in your SP List again, check if the issue is solved.

 

If the issue still exists, please consider remove the custom form from your SP List, then re-create a new one for your SP List, then run your custom form again, check if the issue is solved.

 

If you have solved your problem, please go ahead to click "Accept as Solution" to identify this thread has been solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-xida-msft 

 

Hi im currenlty having this issue.

I have a heavly customise form. RequestHide is not working in Edge but working in Chrome.
I have cleared cahce and everything.

 

If i create a new list and a new form the same RequestHide code works in both Edge and Chrome.

 

What is the steps i can take, i cannot delete and re-create this form as it will take hours to do so.

Hi @chmoncayMSFT ,

 

I am still having problems with this issue. I reverted to SP form, deleted the custom PA form and then recreated, cleared cache and yet the Save button still does nothing. 

 

Could you please share the instructions for adding the additional button and how to use the code you referenced?

 

Much appreciated!

Hi there,

I got this to work by adding this to the OnSuccess field of the SharePointForm:

Refresh('Name of your list'); ResetForm(SharePointForm1); RequestHide()

Thanks to @RandyHayes  

I am having the reverse problem. In some instances, I want this window to remain open until further user interaction. However, whenever the form is submitted, it behaves as though RequestHide() is being called when it is not.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Top Kudoed Authors
Users online (33,350)