cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MRNBagtas
Advocate I
Advocate I

Attachment deleted on phone (android)

Hi, All!

 

We encountered an error that when an attachment is added in a form, when submitted the selected attachment (example: photo) was deleted on the phone. 


This only encountered in android phone, but not on ios. 

 

We found a similar thread but no solution was given: https://powerusers.microsoft.com/t5/General-Discussion/The-file-is-deleted-in-phone-photo-gallery-wh...

Any advise on this please?

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi, @v-monli-msft , everyone!

 

Great news! There was an update on PowerApps last Fridat (March 8), which included the fix for this. 

 

Just tested the functionality now and attachments are not deleted anymore from its original location/storage upon attaching/adding it to powerapps.

 

 

View solution in original post

4 REPLIES 4
v-monli-msft
Community Support
Community Support

Hi @MRNBagtas,

 

Did you mean that after adding attachment to attachment control inside an edit form, it does not save to the item? I just tested with an Andriod phone and I cannot reproduce your issue. Can you please try to test on anothe mobile? Did you make sure that your PowerApps is up-to-date? Also, try to add other type of attachments like word/excel file to test.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi, @v-monli-msft!

 

Please see the updates below:

 

Did you mean that after adding attachment to attachment control inside an edit form, it does not save to the item?

-- I can actually save the item. The problem is, once the item is saved, it will be deleted on the storage where the item came from (for example: attaching picture from gallery. Once attached to the form and saved, or even cancel the attaching, the picture will be deleted from the gallery.)

 

This error only happens on android phones.

 

Thanks!

Hi, @v-monli-msft !

 

This was already raised to Microsoft and they indeed confirmed that this is a bug. Will update you on their next response. 

 

Thank you very much!

Hi, @v-monli-msft , everyone!

 

Great news! There was an update on PowerApps last Fridat (March 8), which included the fix for this. 

 

Just tested the functionality now and attachments are not deleted anymore from its original location/storage upon attaching/adding it to powerapps.

 

 

View solution in original post

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (17,233)