cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LeVentriloque
Regular Visitor

Attachment picture in a gallery failed to open since one week

Hello,

 

I have a gallery with an image. This code show the last photo in attachment (french code in Image):

Last(ThisItem.'{Attachments}').Value

It's running well since one year on my apps, and it's running well in the published version of my apps.

I want to modify my apps but now i have a message incorrect type, table expected and no photo on the screen.

 

I made a copy of my the previous version of my apps with another name and try to publish it but the problem is still there.

I also create new lists in sharepoint but it's the same thing.

 

The published version of my apps is 322084.17 and actual version is 322094.18  

Is there a change about attachment or a bug in the last version ?

 

rgds,

 

Seb

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

@LeVentriloque 

 

1. Click Settings

2. Click Support

3. Click Edit

poweractivate_3-1665316353945.png

 

4. Click dropdown Authoring version and select the oldest possible version 3.22085.14 from the dropdown

poweractivate_4-1665316390423.png

 

 

5. Click Reload + apply version

poweractivate_2-1665316347635.png

 

 

Does the issue persist after doing the above steps?

 

If the issue does not persist, it could be an indication that the current authoring version has changed something in an unexpected way. If so,

Create a new Power Platform Support Ticket

because even if reverting the authoring version works now, it may not work in the future, so you should contact support and report the issue.

 

Even if the issue doesn't persist, I recommend you should

Create a new Power Platform Support Ticket

just in case,

maybe there is still some issue if it just suddenly stopped working like that.

 

You can also try to check on the error, see where it is expecting a Table, and then try something like this:

//example
Last(ThisItem.'{Attachments}').Value

//or
ThisItem.'{Attachments}'

//or
ThisItem.'{Attachments}'.Value

Again, the above would be temporary, you should check with Power Platform support team because you probably should not be required to make this change - you should confirm it with them for sure whether or not you should really make that kind of change to your existing apps.

View solution in original post

6 REPLIES 6

@LeVentriloque 

 

1. Click Settings

2. Click Support

3. Click Edit

poweractivate_3-1665316353945.png

 

4. Click dropdown Authoring version and select the oldest possible version 3.22085.14 from the dropdown

poweractivate_4-1665316390423.png

 

 

5. Click Reload + apply version

poweractivate_2-1665316347635.png

 

 

Does the issue persist after doing the above steps?

 

If the issue does not persist, it could be an indication that the current authoring version has changed something in an unexpected way. If so,

Create a new Power Platform Support Ticket

because even if reverting the authoring version works now, it may not work in the future, so you should contact support and report the issue.

 

Even if the issue doesn't persist, I recommend you should

Create a new Power Platform Support Ticket

just in case,

maybe there is still some issue if it just suddenly stopped working like that.

 

You can also try to check on the error, see where it is expecting a Table, and then try something like this:

//example
Last(ThisItem.'{Attachments}').Value

//or
ThisItem.'{Attachments}'

//or
ThisItem.'{Attachments}'.Value

Again, the above would be temporary, you should check with Power Platform support team because you probably should not be required to make this change - you should confirm it with them for sure whether or not you should really make that kind of change to your existing apps.

Thanks a lot for this solution, it's working well now.

What is the raison about it, deprecated code or bug in the last powerapps version ?

 

Seb

@LeVentriloque 

 

I don't know the reason, I am surprised it even worked.

To find the reason, check these steps:

Create a Power Platform Support Ticket

 

Even if my solution works now, it may stop working at any time in the future, the "solution" I gave is a temporary troubleshooting measure, or to keep the app working temporarily in case. You should start a support ticket as soon as possible here and find out why it is not working in the current authoring version

 

 

Hi,

 

I can't open support ticket because i'am not an administrator. I'll try to contact the powerapps administrator in my company. If i obtain an answer about this problem i'll write the issue here.

Thanks for your help.

 

Seb

 

@poweractivate I faced the similar issue. Your guideline has helped me resolve the issue. Many thanks

LeVentriloque
Regular Visitor

Hi,

 

Thangdang have open a support ticket for me about this issue. Microsoft engineers aknowledge the problem and work on it. It’s just a question of time, the code will work again in future power apps version.

 

Rgds

 

Seb

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (3,815)