cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
pieromontas
Level: Powered On

Attachments Fields not showing SP2016

I Have a custom list in SharePoint 2016 when I create a powerapp App connected to that list is not showing me any attachment options.

 

 

4 REPLIES 4
Community Support Team
Community Support Team

Re: Attachments Fields not showing SP2016

Hi @pieromontas,

 

I have made a test on my side and don't have the issue that you mentioned. The screenshot as below:8.JPG

 

 

I could not reproduce your issue on my side currently, please check if you have disabled the "Attachments to list items" option within Advanced settings of the List Settings as below:9.JPG

 

 

If you have disabled the "Attachments to list items" option, please enable this option on your side, then refresh the SharePoint list data source within your PowerApps app to check if the issue is solved.

 

More details about disabling or enabling "Attachments to list items" option within SharePoint list, please check the following article:

https://social.technet.microsoft.com/wiki/contents/articles/30024.sharepoint-online-disable-or-enabl...

 

In addition, please take a try to re-create a new SharePoint list and a new PowerApps app on your side, then add this SP list into your PowerApps app as a data source, then check if the issue is solved.

 

Best regards,

Kris

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
pieromontas
Level: Powered On

Re: Attachments Fields not showing SP2016

Already did all that and I also try it with my SharePoint online environment and with SharePoint online works the problem is with my on-prem SharePoint 2016 using a custom list.

Gaëlle
Level 8

Re: Attachments Fields not showing SP2016

 Hi there,

I have the same issue with a SP2013 OnPrem environment.

I did everything @v-xida-msft said, but still no "HasAttachment" showing in any of my Forms (Edit nor Display).

Did you find a solution, @pieromontas ?

Could someone help me please ?

Gaëlle
Level 8

Re: Attachments Fields not showing SP2016

Okay, nevermind, I have the answer I needed, by @v-xida-msft but on another post :

Attachments seems not to be a feature available for On-Prem SP datasource.

 

Source :

https://powerusers.microsoft.com/t5/General-Discussion/Attachment-Column-not-available-with-SharePoi...

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,975)