cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AvinashRaju
Regular Visitor

Attachments not displaying on screen- after navigation to different screen

Hi,

I have created a Powerapp and currently have 3 screens, one for edit, display and new.

When i edit and existing item and attach any files to it, after submit(), the screen navigates to a display screen, on the display screen the attached file is not showing up. 

But when i close the app and open a  new session the attachments are visible.

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @AvinashRaju ,

Your issue should be caused by data delay.

I suggest you add refresh action before you submit the form and after you submit the form, which could help you reduce this kind of problem.

For example:

Refresh(datasource);SubmitForm(..);Refresh(datasource)

If your data is very large, it will effect your app's performance which will lead to data delay too.

Here are some tips about improving your app performance for your reference:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/performance-tips

https://powerapps.microsoft.com/en-us/blog/performance-considerations-with-powerapps/

 

What's more, please try to clear your browser's cache and update it to the latest version.

If your browser's cache is too large, it will lead to many problems.

 

 

Best regards,

 

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Digital
Continued Contributor
Continued Contributor

Where are you submitting your form to? Maybe the display screen is not displaying the updated data and needs to be refreshed.

I am submitting it to a SharePoint list.

I was able to resolve this issue by removing the refresh data source on the OnVisible setting for display screen, somehow it takes time or just doesn't show up the attachments.

 

But i am facing another issue, if i click on submit on powerapps form it needs to save the data and start a Flow, it is able to do this successfully, but the flow itself updates few fields and those changes are not being reflected on the powerapps form once the form navigates.

 

Maybe i should start a new thread for this.

Hi @AvinashRaju ,

Your issue should be caused by data delay.

I suggest you add refresh action before you submit the form and after you submit the form, which could help you reduce this kind of problem.

For example:

Refresh(datasource);SubmitForm(..);Refresh(datasource)

If your data is very large, it will effect your app's performance which will lead to data delay too.

Here are some tips about improving your app performance for your reference:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/performance-tips

https://powerapps.microsoft.com/en-us/blog/performance-considerations-with-powerapps/

 

What's more, please try to clear your browser's cache and update it to the latest version.

If your browser's cache is too large, it will lead to many problems.

 

 

Best regards,

 

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (2,129)