cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AvinashRaju
Regular Visitor

Attachments not displaying on screen- after navigation to different screen

Hi,

I have created a Powerapp and currently have 3 screens, one for edit, display and new.

When i edit and existing item and attach any files to it, after submit(), the screen navigates to a display screen, on the display screen the attached file is not showing up. 

But when i close the app and open a  new session the attachments are visible.

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @AvinashRaju ,

Your issue should be caused by data delay.

I suggest you add refresh action before you submit the form and after you submit the form, which could help you reduce this kind of problem.

For example:

Refresh(datasource);SubmitForm(..);Refresh(datasource)

If your data is very large, it will effect your app's performance which will lead to data delay too.

Here are some tips about improving your app performance for your reference:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/performance-tips

https://powerapps.microsoft.com/en-us/blog/performance-considerations-with-powerapps/

 

What's more, please try to clear your browser's cache and update it to the latest version.

If your browser's cache is too large, it will lead to many problems.

 

 

Best regards,

 

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Digital
Helper V
Helper V

Where are you submitting your form to? Maybe the display screen is not displaying the updated data and needs to be refreshed.

I am submitting it to a SharePoint list.

I was able to resolve this issue by removing the refresh data source on the OnVisible setting for display screen, somehow it takes time or just doesn't show up the attachments.

 

But i am facing another issue, if i click on submit on powerapps form it needs to save the data and start a Flow, it is able to do this successfully, but the flow itself updates few fields and those changes are not being reflected on the powerapps form once the form navigates.

 

Maybe i should start a new thread for this.

Hi @AvinashRaju ,

Your issue should be caused by data delay.

I suggest you add refresh action before you submit the form and after you submit the form, which could help you reduce this kind of problem.

For example:

Refresh(datasource);SubmitForm(..);Refresh(datasource)

If your data is very large, it will effect your app's performance which will lead to data delay too.

Here are some tips about improving your app performance for your reference:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/performance-tips

https://powerapps.microsoft.com/en-us/blog/performance-considerations-with-powerapps/

 

What's more, please try to clear your browser's cache and update it to the latest version.

If your browser's cache is too large, it will lead to many problems.

 

 

Best regards,

 

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Top Kudoed Authors
Users online (30,510)