cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Attachments with a form not saving

I have built a form to upload data into a list.

 

My user has a requirement to add attachments when a new record is entered via the form.

 

I have added the Attachments DataCard to my form, and when I click I get the standard explorer to find a file, which then is listed in the form but has "Unsaved" next to it.

 

If I submit the form the attachments column has a paper clip in it, but I cannot see or access any attachments.

 

Help! 😞

 

Scott

5 REPLIES 5
Highlighted
Super User
Super User

Re: Attachments with a form not saving

Do you have a screen shot?  Is the attachment actually attached to the  list (sharePoint?) but not showing on your form?

Highlighted
Community Support
Community Support

Re: Attachments with a form not saving

Hi @Scootteruk ,

Could you please share a bit more about your issue?

Do you mean that the Attachments control within your Edit form could not save attachments into your SP list?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

When you attach files using the Attachments control within your Edit form, the new attached file would be recognized as "Unsaved":8.JPGOnce you submitted your record, and then edit the previous submitted record (attached with attachments) within your app, the uploaded files would be existed within the Attachments control:9.JPG

Please consider re-generate a new app based on your SP List, then enable the "Attachments" data card within your Edit form, submit a new record along with some attachments, then check if the issue is solved.

 

More details about generating an app based on SP list data source, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/app-from-sharepoint

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Frequent Visitor

Re: Attachments with a form not saving

Upon submission of the form, the files are not saved and are no longer shown on the form when you edit from the SP list.

 

In fact, when I edit from the SP List, none of the data entered is present on the form it is a blank form

 

Any ideas?

Highlighted
Dual Super User III
Dual Super User III

Re: Attachments with a form not saving

Hi, 

 

Please refer to this post. Another user had this problem and the sugeestions have helped them. 

 

https://powerusers.microsoft.com/t5/General-Discussion/Unable-to-attach-in-Powerapps-form/m-p/289456...

 

Thanks, 

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Super User
Super User

Re: Attachments with a form not saving

Do you have allow attachments turned on in the List Setting - Advanced

Helpful resources

Announcements
Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Super Users Coming in August

We are excited for the next Super User season.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (3,827)