cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cfebvre
Advocate V
Advocate V

'Auto Pause' property on Timer control not working on live version - New Form

Hi All,

 

I have a Refresh(Data Source) function attached to the 'On Timer End' property of a Timer Control.

The Timer itself sits on my Gallery Screen.

I also have the 'Auto Pause' property of the Timer Control set to 'true'.

According to the documentation, setting auto pause to 'true' should pause the timer when a user navigates to a new screen.

 

I also have a 'Create New' button which creates a new form and navigates to the Form Screen.

 

While I am editing and testing (previewing) my app the 'Auto Pause' function works as you would expect. The timer pauses and the Data Source won't refresh when I navigate to the Form Screen.

 

Once I publish and the run the app, however, this 'Auto Pause' function appears to stop working, the timer will continue, and will refresh the data source while users are filling out a form.

 

This is causing a problem as I have a 'Multi line' Text field in my form, and while users are editing the multi line text field, the cursor will jump to the bottom of the field, even if they have the cursor placed in the middle of a sentence when the Data Source is refreshed at the Timer's end.

5 REPLIES 5
JayMagness
Super User
Super User

HI,

 

Look and make sure the Timer Control is located in the proper structure..

 

Either Screen, Canvas, Form, etc....

 

Jay

silvadev-cdba
New Member

I'm facing the same issue... 

 

The only thing mytimer does is to navigate to Home, but then the user can't leave Home as it will redirects again to Home over and over.

 

silvadev-cdba_0-1597057282843.png

 

@silvadev-cdba 

 

For yours it sounds like you have it doing an AutoStart = true. Instead tell it when you want it started. So the screen you do want it started on you can have the OnVisible: Set(varTimerStart, false);Set(varTimerStart,true) and then the timer OnStart is varTimerStart.

 

This will give you control on when you want it to start and when you don't.

Hi @rebeccas,

Yeah, I solved my issue doing something similar to what you've suggested. But it is weird that it only happens on LIVE published version, isn't? 

 

I can't reproduce the issue using "debug/preview/play" mode. Or even monitoring (using Monitor tool) attached to Live/published version it works fine. It auto pauses as it should when navigating to another screen.

 

Thanks in advance.

@silvadev-cdba 

 

I find the timers have a lot of "odd" behavior in general. I don't depend on any of the settings that are built into it. Like the Reset=true...often does not work so I force it. I find a lot of uses for the timers but I find the settings that are built in with it are very inconsistent so I typically don't rely on them. 

 

Your issue is odd...more often I find stuff that works in Play mode and not in Edit but occasionally I do see some work the way yours did....or should I say "not work"...lol. 

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Did you miss the call? Check out the recording here!

Top Solution Authors
Top Kudoed Authors
Users online (36,664)