cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Auto populate form fields from another SharePoint list

 

I created a SharePoint list with two columns - Role (Title) and Person 

 

Role     Person

CIO      Person A

CFO     Person B

CEO     Person C

 

In my PowerApps Form (separate SP list), I would like to populate three fields with the Person above. 

 

Example: 

 

I want to populate the following fields when the form is open :

 

  1. "IT Approval" with Person A
  2. "Finance Approval" with Person B
  3. "Management Approval" with Person C

 

All the fields above are Person field in both SharePoint lists. 

 

How do I set it up so that the above form fields are auto-populated when the form loads. 

 

Thanks. 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User
Super User

@Raeville

 

Set the defaults property of "IT Approval" to

 

Lookup(SharepointListwithCIOCFOCEOnames, Role="CIO",Person)

 

and similarly for the other roles.

 

Hope this helps!


Vivek Bavishi aka That API Guy
PowerApps and Flow MVP
Blog | Twitter | YouTube | Community Profile | GitHub



If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Highlighted
Super User
Super User

@Raeville

 

Set the defaults property of "IT Approval" to

 

Lookup(SharepointListwithCIOCFOCEOnames, Role="CIO",Person)

 

and similarly for the other roles.

 

Hope this helps!


Vivek Bavishi aka That API Guy
PowerApps and Flow MVP
Blog | Twitter | YouTube | Community Profile | GitHub



If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted

HI @ThatAPIGuy

 

When i put the formula in the default property, it worked a treat. However, doing that meana i'm defaulting the data card value to the Lookup value. It is good when i open up a new form, but it will still show up as the default value when i open in edit/view mode. The SharePoint list item will show the correct value, but when clicked into PowerApps, it shows the default value. 

 

I'm doing this on a customised form. 

 

Do you know how i can overcome the value discrepancies?

 

Thanks again. 

Highlighted

Create a ContextVariable on your Button Select for New and Edit e.g.

 

UpdateContext({CustomForm:"New"})
UpdateContext({CustomForm:"Edit"})

 

Then use an If Statement in the Default Propery e.g.

 

If (CustomForm = "New", Lookup....., Blank())

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (10,601)