cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Azure SQL Server database calls takes minutes instead of seconds

Since today everyone using the app noticed extreme delays. After my investigation, it seems that the calls to Azure SQL Server are taking minutes instead of seconds. Was anything changed in PowerApps that impact the load times so much? The app was working perfectly (database calls taking few seconds) until today.

 

Strangely enough, the Azure SQL Server actually hosts two databases for two separate apps. Other app database call times are fine it seems that only the other app is affected. Moreover, the app which is super slow today has the better database (S2 Standard 50 DTUs vs Basic 5 DTUs).

 

Anyone noticing something similar with their apps? Any tips on how to solve? Again, the app was working fast for past two weeks only today everything seems to be extremely slow in the app anytime there is a call to the database.

26 REPLIES 26
dboulet
New Member

I'm also experiencing this. The perfomance is very inconsistent. Sometimes it will be super responsive, but then it'll go through random periods of very sluggish performance. 

 

Is there anything that can be done? Is this on the Azure SQL end, or the Powerapps end? Does anyone have any ideas?

amac1870
Frequent Visitor

Same here. 

Facing same issue right now. I've upgraded my database service doubling DTUs with no success. The issue isn't related to database performance. It's something in the connection.

Bump this up one.  I'm seeing major performance for a PowerApp to Azure SQL on multiple tenants.  We have multiple clients that use the same app/arch and are ALL seeing the slow performance.

Anonymous
Not applicable

I am experiencing the same thing. It's definitely something in the connction, not performance of the database. Really hoping someone from Microsoft responds or acknowledges this so we can expect some sort of resolution or explanation. 

We are experiencing the same issue. 

Anonymous
Not applicable

This is making many production apps unusable. 

Exactly same here. The connection to Azure SQL is so unpredicatble. Well, I would say 70-80% of the time is "Normal", but from time to time, it will hangs, and after 10-15 mins, it will come back to normal. Out tempory solution is to create another same connection with diffrent names, every time one connection hangs, we ask our user to "switch" to another connection. And the app can work normally.

 

We check the Azure SQL Server and everything looks fine. Out guess is the connection from Powerapps to Azure got stuck for some reason. Seeing so many people suffered from this issue makes me thing this is a bug of Powerapps. Please try to find out the cause of the issue and fix it. Thanks.

The performance seems a lot of better this week. Anyone else still has this issue yet?

I don't think so. I've users reporting slowness today.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Top Kudoed Authors
Users online (51,940)