cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ericonline
Community Champion
Community Champion

BUG: App Unusable in Editing Env

Wow. Something bad just happened. 

 

I saved my app, then shortly after my laptop died (like 3 seconds later). When logging back in, the app has a gray screen and NO elements are selectable. 

 

All elements are visible in the left nav, but NONE of them are visible on the screen. 

 

2018-07-31_10-09-02.png

 

Does anyone know how to recover something like this? I've tried RESTORING from previous versions but NO RESTORES actually restore. 

1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous
Not applicable

I posted something similar to this over the weekend but my thread got marked as spam.  

https://powerusers.microsoft.com/t5/General-Discussion/Bug-Blank-View-when-attempting-to-edit-App/td...

 

For me it kind of just resolved on it own which is not a vote of confidence in knowing what went wrong.  Likely a new update of PowerApps caused this...will leave this with the PowerApps team to assist.  Not sure it's the editor or some update causing our content to go blank or become misformatted. 

 

Blank_Edit.png

 

I've been also trying to help bring awareness in this other thread. 

https://powerusers.microsoft.com/t5/General-Discussion/App-Editing-not-working/m-p/140990#M48477

 

-Sidney

View solution in original post

5 REPLIES 5
Anonymous
Not applicable

I posted something similar to this over the weekend but my thread got marked as spam.  

https://powerusers.microsoft.com/t5/General-Discussion/Bug-Blank-View-when-attempting-to-edit-App/td...

 

For me it kind of just resolved on it own which is not a vote of confidence in knowing what went wrong.  Likely a new update of PowerApps caused this...will leave this with the PowerApps team to assist.  Not sure it's the editor or some update causing our content to go blank or become misformatted. 

 

Blank_Edit.png

 

I've been also trying to help bring awareness in this other thread. 

https://powerusers.microsoft.com/t5/General-Discussion/App-Editing-not-working/m-p/140990#M48477

 

-Sidney

View solution in original post

@Anonymous you are awesome!!

 

also had Apps Settings > Render Classic Mode turned on (so I could drag and drop Form fields!).

 

Steps to "fix":

  • Turn Render Classic Mode OFF
  • Save As "someotherAppName"
  • Close browser tab
  • Open new browser tab
  • Open "someotherAppName"

App is back... sheesh! Heart stopper as 8/1 is the deliverable date for this app. 

Anonymous
Not applicable

@ericonline - Glad it resolved for you.  That's my biggest worry for something to break my App on its own.  

Something else super cool here...

 

Your response to my post was faster than the official response from a PowerApps support ticket (which is already REALLY fast). 

 

Way to go PowerApps Community!!

For me, today, September 12, 2018, I couldn't drag and drop form fields unless I turned "Improve App Rendering" to OFF.

 

TurnRenderOff.jpg

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,370)