cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate III
Advocate III

BUG - Dynamics CRM Custom Entity issue when app having multiple screen for the same custom entity

So, here is the scenario:

I added one data set of custom entity (not an oob entity). Then I created one screeen to "create record" for that entity and another screen to "view all records" which are already exist.

So what happens here? When I developed first screen it worked fine, after that I created second screen and shown some fields on screen. 

After doing this I navigate back to "create record screen" then it shown error for all screen and not able to load the values for that fields.

 

Then to resolve this I have removed data set and re-added it back.

It resolved the issue for the first screen but at the same time it creates issue for my second screen - View record screen.

 

on view record screen I could see the records are there but fields data is not getting populated.

 

I have tried to change the field and get the data,  but I got success to get data only for one field and that was "Created On" date.

 

This all things only happens with custom entity, its working fine with using OOB entities.

 

I am using Dynamics 365 connector to get data sets.

 

Thanks,

Milansinh Raj

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors
Users online (6,049)