cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KC
Kudo Kingpin
Kudo Kingpin

BUG: Editor Properties and Screens Panels disappear and menus are disabled after preview mode of a Datatable

Started seeing this last Friday, Jun 26, 2019,

in a clients PowerApps Environment.

 

This behavior is present in both 

Microsoft Edge and Chrome Browsers

While in the Web Editor:

  1. Click the Preview button
  2. Navigate to screen with a DataTable
  3. Click the X to close and go back to editing.

The Screen shrinks to Editor size but the side panels,

the Screens Tree view and the Properties panels are both missing and main menus do nothing.

Close button is also disabled.

 

Only recourse is to close the app and launch once more.

Clearing all cache in either browers has no affect.

Fortunatley Production app is not affected.

 

Chrome: Version 75.0.3770.100

Microsoft Edge: 42.17134.1.0

 

PowerApps Version: 3.19062.18

APPID: 3aa4dd04-3859-4ad3-ac18-2e6e5e9b05b9

 

UPDATE:

  1. Sorry I did not see this until now but the X Button does not actually put you back into edit mode, you still remain in Preview Mode.
  2. Edited another app using PowerApps version 3.19022.17 the issues above are not present.

 

 

 

 

10 REPLIES 10
sunnyfork
Frequent Visitor

Hi, same problem here:
https://powerusers.microsoft.com/t5/General-Discussion/Bug-Screens-with-data-table-have-javascript-e...

So it seems the data table is the cause of this problem.
LRVinNC
Resident Rockstar
Resident Rockstar

I don't know if this may be related or not but a couple hours ago I had the last 3 screens disappear off my tree.  They simply weren't there.  I knew I had not deleted them.  I closed the app and restarted and they were where they were supposed to be again.

LRVinNC

------------------
Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

 

@sunnyfork Ah! I should have checked your post first. Hopefully this is resolved soon.

PaulD1
Community Champion
Community Champion

I'm also seeing this issue.

The navigation and property panes become unresponsive or disappear altogether and the activiy indicator runs constantly. Only option is to close and reopen Studio in the browser.

App runs fine in Web and Android players.

First noticed it sometime last week.

PaulD1
Community Champion
Community Champion

Update: Deleted all the data tables in my App (was only using them to view the state of variables during testing) and so far the problem appears to be resolved for me.

KC
Kudo Kingpin
Kudo Kingpin

I'll try your solution.

Thank you Paul

Anonymous
Not applicable

Hi All,

 

Is anyone still experiencing this issue?

 

@Anonymous 

@Anonymous As of this morning,

I'm not seeing this issue any longer and the PowerApps release version is now 3.19063.12

Anonymous
Not applicable

Thanks for the follow up @KC . I'm going to leave the thread open for now in case this issue pops up again. 

 

@Anonymous 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Top Kudoed Authors
Users online (1,817)